This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 154323 - xfsprogs 2.7.3 are released
xfsprogs 2.7.3 are released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xfsprogs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
ftp://oss.sgi.com/projects/xfs/downlo...
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-04-09 17:36 EDT by Robert Scheck
Modified: 2013-07-02 22:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: 2.7.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 10:30:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xfsprogs-2.6.25-gcc4.patch (7.76 KB, patch)
2005-04-09 17:37 EDT, Robert Scheck
no flags Details | Diff
Diff from xfsprogs 2.6.13 to 2.6.36 spec file (2.30 KB, patch)
2005-08-28 12:55 EDT, Robert Scheck
no flags Details | Diff
Diff from xfsprogs 2.6.13-5 to 2.7.3-1 spec file (2.40 KB, patch)
2005-11-04 19:50 EST, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2005-04-09 17:36:29 EDT
Description of problem:
xfsprogs 2.6.25 were released at December 12th, 2004 while Fedora Core 
Development hangs around at 2.6.13.

Version-Release number of selected component (if applicable):
xfsprogs-2.6.13-3

Actual results:
xfsprogs 2.6.25 need a patch for rebuilding with gcc 4.0 - like the currently 
used 2.6.13 one. 

I merged my patch from bug #153968 for the newer xfsprogs; but I'm not sure,
whether my patch is correct - but it still works for me ;-)

Expected results:
Upgrade to 2.6.25... ;-)
Comment 1 Robert Scheck 2005-04-09 17:37:49 EDT
Created attachment 112917 [details]
xfsprogs-2.6.25-gcc4.patch
Comment 2 Robert Scheck 2005-05-29 08:27:33 EDT
Marking as a todo for FC5 - because FC4 is frozen, yet :-(
Comment 3 Robert Scheck 2005-08-27 19:00:32 EDT
Ping? Hey Jeff - or other Red Hat guys - wake up, please ;-)

Even xfsprogs 2.6.36 were released on August 1st, 2005 and nothing happend in 
Fedora Core Development!
Comment 4 Robert Scheck 2005-08-28 12:55:33 EDT
Created attachment 118194 [details]
Diff from xfsprogs 2.6.13 to 2.6.36 spec file

Okay...here is, what you maybe wanted the whole time for - a pre-masticated and
clean diff/patch. And can we *please* get this patch soon into Rawhide, thank
you very much! ;-)
Comment 5 Robert Scheck 2005-11-04 19:47:55 EST
Florian, I'm adding you as Cc, because you were the last person, who modified 
xfsprogs. I still can't understand why the xfsprogs aren't upgraded for such 
long time?!

Is there a plan to remove xfsprogs support from Fedora or is the original 
maintainer no longer working for Red Hat - or is my suggested patch not sane?

Patch from 2.6.13-5 to 2.7.3-1 is following in a few minutes. Would be very 
nice, if somebody could check and apply it to CVS, if it's sane. Thanks! :)
Comment 6 Robert Scheck 2005-11-04 19:50:45 EST
Created attachment 120748 [details]
Diff from xfsprogs 2.6.13-5 to 2.7.3-1 spec file

Okay, here's my christmas present for Red Hat ;-)
Comment 7 Robert Scheck 2005-11-11 10:30:15 EST
Florian, thank you very much for committing to CVS and building in Rawhide, 
closing now.

Note You need to log in before you can comment on or make changes to this bug.