Bug 1543398 - Neutron API container exec command misalignment
Summary: Neutron API container exec command misalignment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Ricardo Noriega
QA Contact: Roee Agiman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-08 11:46 UTC by Ricardo Noriega
Modified: 2018-06-27 13:45 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:43:30 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1748173 None None None 2018-02-08 11:46:20 UTC
OpenStack gerrit 542264 None master: MERGED tripleo-heat-templates: Adding /usr/share/neutron/server config dir (I22023a645c4752c6371b5cea5ab69c7503991887) 2018-03-29 16:02:24 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:45:00 UTC

Description Ricardo Noriega 2018-02-08 11:46:21 UTC
Description
==============

In a non-containerized deployment, neutron server starts with the following command given by the rpm spec:

https://github.com/rdo-packages/neutron-distgit/blob/rpm-master/neutron-server.service#L8

ExecStart=/usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-dir /usr/share/neutron/server --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --config-dir /etc/neutron/conf.d/common --config-dir /etc/neutron/conf.d/neutron-server --log-file /var/log/neutron/server.log
However, in a containerized deployment, this command is defined in the neutron-api docker service, specifically in the kolla_config command:

https://github.com/openstack/tripleo-heat-templates/blob/master/docker/services/neutron-api.yaml#L104

command: /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --config-dir /etc/neutron/conf.d/common --config-dir /etc/neutron/conf.d/neutron-server

As you can ses, the config folder /usr/share/neutron/server is not loaded in a containerized deployment, which causes neutron to fail when loading l2gw or bgpvpn service_plugins for example.

Steps to reproduce
==================

Deploy containerized Neutron service.

Expected result
===============

To have /usr/share/neutron/server as config-dir in neutron_api container exec command.

Actual result
==============

That directory is not loaded.

Comment 8 errata-xmlrpc 2018-06-27 13:43:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.