Bug 1543633 - Wacom Mode Switching Not Working
Summary: Wacom Mode Switching Not Working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter
Version: 7.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-08 21:04 UTC by Michael Boisvert
Modified: 2018-05-17 14:39 UTC (History)
7 users (show)

Fixed In Version: mutter-3.26.2-13.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 13:11:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 13:12:39 UTC

Description Michael Boisvert 2018-02-08 21:04:12 UTC
Description of problem: Many Wacom tablets have a keyring with 2-4 modes it can be used for. Typically, there are LEDs that indicate the current mode. As of RHEL7.5, mode switching is not working. When you press the mode switching button, the LED stays in place at MODE1 and the mode is not changed. However, you can map what the keyring does in MODE1 within the Wacom Tablet settings. 

I see button press event in xinput test-xi2, but I was not sure which component was causing the issue.

Steps to Reproduce:
1. Plug in any Wacom tablet with mode switching.
2. Hit the mode switch button

Actual results: No mode change, no LED change.

Expected results: Mode switched through the full range and the LED indicates which mode the keyring is in.

Comment 9 Michael Boisvert 2018-02-23 19:52:27 UTC
Pleased to report that the fix in mutter-3.26.2-13.el7 includes a small OSD indicating which mode you switched to. On top of that, mode switching now works in 7.5.

Comment 12 errata-xmlrpc 2018-04-10 13:11:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.