Bug 1543647 - Remove hawkular-alerts from hawkular-metrics
Summary: Remove hawkular-alerts from hawkular-metrics
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.9.0
Assignee: John Sanda
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1492159
TreeView+ depends on / blocked
 
Reported: 2018-02-08 22:56 UTC by John Sanda
Modified: 2018-05-17 06:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
The Hawkular Alerts components has been removed from Hawkular Metrics. This change has no functional impact on Hawkular Metrics.
Clone Of:
Environment:
Last Closed: 2018-05-17 06:42:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
cache-container named hawkular-alerts is not removed from standalone.xml (27.36 KB, text/plain)
2018-04-12 01:51 UTC, Junqi Zhao
no flags Details
cache-container named hawkular-alerts is removed from standalone.xml (26.23 KB, text/plain)
2018-04-20 01:32 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:43:24 UTC

Description John Sanda 2018-02-08 22:56:28 UTC
Description of problem:
Hawkular Alerts has been packaged with Hawkular Alerts for the past few (maybe more) versions of OCP. Because Hawkular Alerts has never been supported and because of changes in future plans around Hawkular Metrics, it no longer makes sense to continue packaging Hawkular Alerts. It is a burden in that it creates extra support and maintenance work. When we need to upgrade a common library, e.g., the Cassandra driver, we cannot perform the upgrade solely in Hawkular Metrics. We also have to perform the upgrade in Hawkular Alerts. This is because of some class loading issues with the way things are packaged inside of the WildFly application server. This creates a lot of extra work in terms of productization builds. 

We can reduce the deployment unit from a complex EAR file to a much more simple WAR file that only includes Hawkular Metrics. This simplifies iterative development and testing as well. There is a good bit of custom configuration done to WildFly for Hawkular Alerts. That will no longer be needed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 9 Junqi Zhao 2018-03-05 02:26:19 UTC
Issue is not fixed, it is changed to ON_QA by errata, change back to MODIFIED

The following war packages are still in hawkular-metrics.ear
hawkular-alerts-action-elasticsearch.war
hawkular-alerts-action-email.war
hawkular-alerts-action-webhook.war
hawkular-alerts.war

Imges:
metrics-cassandra-v3.9.2-1
metrics-hawkular-metrics-v3.9.2-1
metrics-heapster-v3.9.2-1

Comment 11 Junqi Zhao 2018-03-23 09:10:44 UTC
checked in metrics-hawkular-metrics/images/v3.9.14-1, only hawkular-metrics.war is left now, and sanity testing is passed.

This defect can move to ON_QA now

# oc rsh ${hawkular-metrics-pod}
sh-4.2$ ls -alR /opt/eap/standalone/deployments/
/opt/eap/standalone/deployments/:
total 25480
drwxrwxrwx. 1 jboss      jboss       76 Mar 23 08:55 .
drwxr-xr-x. 1 root       root       113 Mar 23 08:54 ..
-rw-rw-rw-. 1 jboss      root      8870 Apr 18  2016 README.txt
-rw-r--r--. 1 jboss      jboss  8428797 May 23  2016 activemq-rar.rar
-rw-r--r--. 1 1000040000 root        16 May 23  2016 activemq-rar.rar.deployed
-rw-r--r--. 1 root       root  17637762 Mar  6 01:51 hawkular-metrics.war
-rw-r--r--. 1 1000040000 root        20 Mar  6 01:51 hawkular-metrics.war.deployed

Images:
metrics-hawkular-metrics-v3.9.14-1
metrics-heapster-v3.9.14-1
metrics-cassandra-v3.9.14-1

Comment 13 Junqi Zhao 2018-04-12 01:51:14 UTC
cache-container named hawkular-alerts is not removed from standalone.xml.
See the attached file

env:
# openshift version
openshift v3.9.20
kubernetes v1.9.1+a0ce1bc657
etcd 3.2.16

Images
metrics-cassandra/images/v3.9.14-3
metrics-hawkular-metrics/images/v3.9.14-3
metrics-heapster/images/v3.9.14-3

Comment 14 Junqi Zhao 2018-04-12 01:51:45 UTC
Created attachment 1420616 [details]
cache-container named hawkular-alerts is not removed from standalone.xml

Comment 16 Junqi Zhao 2018-04-20 01:32:18 UTC
hawkular-alerts is removed from hawkular-metrics
# oc rsh ${hawkular-metrics-pod}
sh-4.2$ ls -alR /opt/eap/standalone/deployments/
/opt/eap/standalone/deployments/:
total 28880
drwxrwxr-x.  2 jboss      root      146 Apr 20 00:57 .
dr-xr-xr-x. 20 root       root     4096 Apr 20 00:56 ..
-rw-rw-r--.  1 jboss      root     8888 Nov  3 16:05 README.txt
-rw-rw-r--.  1 jboss      root 11906629 Mar  7 05:37 activemq-rar.rar
-rw-r--r--.  1 1000040000 root       16 Mar  7 05:37 activemq-rar.rar.deployed
-rw-r--r--.  1 root       root 17637762 Mar  6 01:51 hawkular-metrics.war
-rw-r--r--.  1 1000040000 root       20 Mar  6 01:51 hawkular-metrics.war.deployed


cache-container named hawkular-alerts is removed from standalone.xml. see tha attached file.

# openshift version
openshift v3.9.24
kubernetes v1.9.1+a0ce1bc657
etcd 3.2.16

metrics-cassandra/images/v3.9.25-1
metrics-hawkular-metrics/images/v3.9.25-1
metrics-heapster/images/v3.9.25-1

Comment 17 Junqi Zhao 2018-04-20 01:32:59 UTC
Created attachment 1424334 [details]
cache-container named hawkular-alerts is removed from standalone.xml

Comment 20 errata-xmlrpc 2018-05-17 06:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.