Bug 1543693 - Changing pressure curves does nothing
Changing pressure curves does nothing
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter (Show other bugs)
7.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carlos Garnacho
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-08 21:02 EST by Peter Hutterer
Modified: 2018-05-17 10:39 EDT (History)
8 users (show)

See Also:
Fixed In Version: mutter-3.26.2-12.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 09:11:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
0001-backends-x11-wacom-pressure-curve-is-a-32-bit-proper.patch (1.14 KB, patch)
2018-02-08 21:02 EST, Peter Hutterer
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 09:12 EDT

  None (edit)
Description Peter Hutterer 2018-02-08 21:02:01 EST
Created attachment 1393486 [details]
0001-backends-x11-wacom-pressure-curve-is-a-32-bit-proper.patch

Description of problem:
Changing the Wacom stylus tip pressure/eraser pressure changes the dconf setting but not the driver property so it ends up being a visually pleasing noop.

Version-Release number of selected component (if applicable):
mutter-3.26.2-7.el7.x86_64

How reproducible:

Steps to Reproduce:
1. xinput watch-props "Wacom Intuos Pro M Pen stylus"
2. control-center/devices/wacom: change slider for tip pressure
3. bring stylus into proximity of physical tablet
4. observe xinput watch-props output

Actual results:
Some properties change (tablet area, rotation, serial ids) but not the pressure values.

Expected results:
Something like:
Property 'Wacom Pressurecurve' changed.
	Wacom Pressurecurve (301):	75, 0, 100, 25

Additional info:
Mutter expects a wrong property format, afaict the property has been 32 bits since around 2011 and has not changed, mutter expects it to be 8 bits. The mismatch causes change_property to never actually change the property (quietly...)

Patch is attached
Comment 7 Michael Boisvert 2018-02-20 11:52:01 EST
With mutter-3.26.2-12.el7, pressure adjustments work as expected.
Comment 10 errata-xmlrpc 2018-04-10 09:11:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.