Bug 1543709 - Optimize glusterd_import_friend_volume code path
Summary: Optimize glusterd_import_friend_volume code path
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: 3.12
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On: 1539510
Blocks: 1540554 glusterfs-3.12.7
TreeView+ depends on / blocked
 
Reported: 2018-02-09 03:50 UTC by Atin Mukherjee
Modified: 2018-04-06 11:06 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.12.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1539510
Environment:
Last Closed: 2018-04-06 11:06:55 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2018-02-09 03:50:28 UTC
+++ This bug was initially created as a clone of Bug #1539510 +++

Description of problem:

When glusterd restarts and in case there's a version mismatch detected for one of the volumes, glusterd was ending up with updating all the volumes which is a
overkill.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always

--- Additional comment from Worker Ant on 2018-01-29 00:00:30 EST ---

REVIEW: https://review.gluster.org/19358 (glusterd: optimize glusterd import volumes code path) posted (#1) for review on master by Atin Mukherjee

--- Additional comment from Worker Ant on 2018-01-31 04:12:50 EST ---

COMMIT: https://review.gluster.org/19358 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- glusterd: optimize glusterd import volumes code path

In case there's a version mismatch detected for one of the volumes
glusterd was ending up with updating all the volumes which is a
overkill.

Change-Id: I6df792db391ce3a1697cfa9260f7dbc3f59aa62d
BUG: 1539510
Signed-off-by: Atin Mukherjee <amukherj@redhat.com>

Comment 1 Worker Ant 2018-02-09 04:01:04 UTC
REVIEW: https://review.gluster.org/19531 (glusterd: optimize glusterd import volumes code path) posted (#1) for review on release-3.12 by Atin Mukherjee

Comment 2 Worker Ant 2018-03-08 06:44:44 UTC
COMMIT: https://review.gluster.org/19531 committed in release-3.12 by "jiffin tony Thottan" <jthottan@redhat.com> with a commit message- glusterd: optimize glusterd import volumes code path

In case there's a version mismatch detected for one of the volumes
glusterd was ending up with updating all the volumes which is a
overkill.

>mainline patch : https://review.gluster.org/#/c/19358/

Change-Id: I6df792db391ce3a1697cfa9260f7dbc3f59aa62d
BUG: 1543709
Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
(cherry picked from commit bb34b07fd2ec5e6c3eed4fe0cdf33479dbf5127b)

Comment 3 Jiffin 2018-04-06 11:06:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.7, please open a new bug report.

glusterfs-3.12.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/maintainers/2018-March/004303.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.