Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1543771 - Etcd scale-up failed at task "Run variable sanity checks"
Etcd scale-up failed at task "Run variable sanity checks"
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.9.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.9.0
Assigned To: Michael Gugino
Gaoyun Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-09 04:32 EST by Gaoyun Pei
Modified: 2018-03-28 10:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-28 10:27:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 10:27 EDT

  None (edit)
Description Gaoyun Pei 2018-02-09 04:32:34 EST
Description of problem:
When scaling up etcd cluster, the playbook failed as below:
PLAY [Verify Requirements] **************************************************************************************************************************************************

TASK [Gathering Facts] ******************************************************************************************************************************************************
ok: [ec2-54-237-213-42.compute-1.amazonaws.com]

TASK [Run variable sanity checks] *******************************************************************************************************************************************
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: TypeError: 'NoneType' object has no attribute '__getitem__'
fatal: [ec2-54-237-213-42.compute-1.amazonaws.com]: FAILED! => {"msg": "Unexpected failure during module execution.", "stdout": ""}



Version-Release number of the following components:
openshift-ansible-3.9.0-0.41.0.git.0.8290c01.el7.noarch
ansible-2.4.2.0-2.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1.Setup an ocp-3.9 with one single etcd host. Add two new hosts to [new_etcd] group in ansible inventory file, run etcd scale-up playbook
ansible-playbook -i host /usr/share/ansible/openshift-ansible/playbooks/openshift-etcd/scaleup.yml -v


Actual results:


Expected results:

Additional info:
Ansible inventory file and detailed playbook log could be found in attachment
Comment 2 Michael Gugino 2018-02-12 12:24:23 EST
PR Created: https://github.com/openshift/openshift-ansible/pull/7113
Comment 4 Gaoyun Pei 2018-02-26 00:08:49 EST
Verify this bug with openshift-ansible-3.9.0-0.51.0.git.0.e26400f.el7.noarch.rpm.

No such error during running etcd scale-up playbook.
Comment 7 errata-xmlrpc 2018-03-28 10:27:28 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489

Note You need to log in before you can comment on or make changes to this bug.