Bugzilla will be upgraded to version 5.0 on December 2, 2018. The outage period for the upgrade will start at 0:00 UTC and have a duration of 12 hours
Bug 1543995 - Include Intel Omni-Path Architecture (OPA) Release Note
Include Intel Omni-Path Architecture (OPA) Release Note
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: Red_Hat_Enterprise_Linux-Release_Notes-7-en-US (Show other bugs)
7.5
x86_64 Linux
unspecified Severity high
: rc
: 7.5
Assigned To: Lenka Špačková
Lenka Špačková
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-09 14:00 EST by LisaSchupper
Modified: 2018-04-13 10:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Release Note
Doc Text:
Intel® Omni-Path Architecture (OPA) Host Software Intel® Omni-Path Architecture (OPA) host software is fully supported in Red Hat Enterprise Linux 7.5. Intel OPA provides Host Fabric Interface (HFI) hardware with initialization and setup for high performance data transfers (high bandwidth, high message rate, low latency) between compute and I/O nodes in a clustered environment. For instructions on installing Intel® Omni-Path Architecture documentation, see https://www.intel.com/content/dam/support/us/en/documents/network-and-i-o/fabric-products/Intel_OP_Software_RHEL_7_5_RN_J98644.pdf.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-13 10:41:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Omni-Path text with link to appear in RHEL release note (13.43 KB, application/zip)
2018-02-09 14:00 EST, LisaSchupper
no flags Details
Omni-Path text with link to appear in RHEL release note (corrected) (13.48 KB, application/zip)
2018-02-09 14:15 EST, LisaSchupper
no flags Details

  None (edit)
Description LisaSchupper 2018-02-09 14:00:24 EST
Created attachment 1393952 [details]
Omni-Path text with link to appear in RHEL release note

1. Feature Overview:
    a) Name of feature:
    	Include OPA Release Note [text and link]
		
    b) Feature Description:
    	Include OPA Release Note link to document that lists features, bug fixes, and OPA doc set pointer. 

		
2. Feature Details:
    a) Architectures:        

    b) Bugzilla Dependencies:
    	
    c) Drivers or hardware dependencies:    

    d) Upstream acceptance information:
    	
    e) External links:

    f) Severity (H,M,L):     

    g) Feature Needed by:    	

3. Business Justification:
    a) Why is this feature needed?
    	Describe Bug fixes and enhancements.

    b) What hardware does this enable?
    	Intel Omni-Path hfi1

    c) Is this hardware on-board in a system (eg, LOM) or an add-on card?
    	both

    d) Business impact?
    	Required for the success of Omni-Path

    e) Other business drivers:

4. Primary contact at Red Hat, email, phone (chat)
    Don Bayly
    dbayly@redhat.com

5. Primary contact at Partner, email, phone (chat)
    Technical contact:
      Lisa Schupper
      lisa.l.schupper@intel.com
    Management contact:
      Steve Vogel
      steve.vogel@intel.com
Comment 2 LisaSchupper 2018-02-09 14:15 EST
Created attachment 1393954 [details]
Omni-Path text with link to appear in RHEL release note (corrected)

Incorrect document number in first attachment.
Sorry.
Comment 3 Lenka Špačková 2018-03-09 03:34:59 EST
Hello Lisa,
Thank you very much for providing the information. I am adding the note to the RHEL 7.5 Release Notes.

This link:
https://www.intel.com/content/dam/support/us/en/documents/network-and-i-o/fabricproducts/Intel_OP_Software_RHEL_7_5_RN_J98643.pdf
returns 404 - is it expected? Will it be active by or at RHEL 7.5 GA?

Thank you for your cooperation!
Comment 4 LisaSchupper 2018-03-09 09:29:28 EST
Hello Lenka,
Yes, the link will be active at that time, most likely sooner than GA.
Thanks and have a wonderful day!
Comment 5 Lenka Špačková 2018-03-13 07:22:33 EDT
Hi Lisa, 
Thanks for the confirmation! 
Have a great day!
Comment 6 Lenka Špačková 2018-03-26 03:34:42 EDT
Hello Lisa,
We have been contacted by Peter Kjellström in a customer portal discussion thread: https://access.redhat.com/discussions/3390091

I'm not sure whether you can access this, so quoting here:

~~~
I downloaded the 7.5beta to see what the state of OPA (Omnipath) support was. Looking at the driver (hfi1.ko) it seems it has seen significant update from 7.4 but there's no mention of it in the "udpated network drivers" section of the release notes.

Maybe this is because the DRIVER_VERSION for that .ko isn't updated correctly? (big diffstat but exactly the same version string...).
~~~

My response confirmed unchanged full support but I don't know about the driver version. Can you help me or find somebody who can? 

Thank you very much!
Best regards,
Lenka
Comment 7 Lenka Špačková 2018-03-26 07:27:23 EDT
Update from Peter:

~~~
I did know of the official "fully supported" status but I am a bit confused about the specifics. In the 7.5beta there seems to be a mix of version wrt various components of the Omnipath support...

opa_fm and similar "toolsl" packages: 10.5 (vs latest from Intel-IFS 10.6) libpsm/libfabric: newer version than latest from intel-IFS 10.6 kernel driver: No idea. Many parts seem about as up to date as 10.6 from Intel-IFS, but it's very different..

Maybe you can try to find some clarification on this for us. We're also interested to know who (if anyone) does testing on this combination of components? Presumably Intel tests IFS (currently 10.6).
~~~

Could your subject matter experts reply to him? Thank you very much!
Regards,
Lenka
Comment 8 LisaSchupper 2018-03-28 10:13:18 EDT
I have added John Fleck (SME) to this bug and pointed him to the discussion thread. 
Thanks!
Comment 9 LisaSchupper 2018-03-28 11:38:58 EDT
Hi Lenka,

Per John:

"The upstream kernel made us remove the driver version, so we stopped updating it.
It is possible the Red Hat kernel has a “stale” version in it.
We are fully supported in RHEL 7.5."

Please let us know if you need more information.

Thanks!
*Lisa
Comment 10 Lenka Špačková 2018-03-29 05:03:45 EDT
Lisa and John,
Thanks a lot for your response, I will reply in the discussion. 
Regards,
Lenka
Comment 11 Lenka Špačková 2018-04-10 10:16:24 EDT
Hello Lisa,
The RHEL 7.5 GA happens to be today, the Release Notes are live:
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/7.5_release_notes/new_features_kernel

but the link to your documentation returns 404. Could you please publish the document asap or send me another link if it has changed?

Thanks a lot!
Best regards,
Lenka
Comment 12 LisaSchupper 2018-04-12 12:18:44 EDT
Hi Lenka,

I apologize for the late response. After troubleshooting this for several days, we discovered that first, it wasn't published and second, the URL I gave you was missing a dash.

Please note that this is the correct link address to use: 
https://www.intel.com/content/dam/support/us/en/documents/network-and-i-o/fabric-products/Intel_OP_Software_RHEL_7_5_RN_J98644.pdf

Again, I apologize for the delays.
Thanks,
*Lisa
Comment 13 Lenka Špačková 2018-04-13 10:40:51 EDT
Hi Lisa,
Thanks a lot for the correct link. I have replaced it in the Release Notes and republished the book:
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/7.5_release_notes/new_features_kernel

Thanks again for your cooperation!
Best regards,
Lenka

Note You need to log in before you can comment on or make changes to this bug.