Bug 1544096 - msg="Your kernel does not support cgroup rt runtime"
Summary: msg="Your kernel does not support cgroup rt runtime"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: docker
Version: 27
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-10 09:15 UTC by Pierre Juhen
Modified: 2018-02-11 15:24 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-11 15:24:16 UTC


Attachments (Terms of Use)

Description Pierre Juhen 2018-02-10 09:15:54 UTC
Description of problem:

docker shows messages 
msg="Your kernel does not support cgroup rt runtime" 
at startup

Version-Release number of selected component (if applicable):

1.13.1-44.git584d391.fc27

is not present in version 

docker-1.13.1-26.gitb5e3294.fc27.x86_64

How reproducible:
Always

Comment 1 Daniel Walsh 2018-02-11 10:58:43 UTC
Not sure what you are reporting.

docker-1.13.1-44.git584d391.fc27 seems to be current in Fedora 27. Does this have support for the cgroup rt runtime?

Comment 2 Pierre Juhen 2018-02-11 14:52:03 UTC
In latest release, when docker starts, if you do a :

systemctl status docker, 

there is a warning :

msg="Your kernel does not support cgroup rt runtime" 

This is not the case with previous version : 

docker-1.13.1-26.gitb5e3294.fc27.x86_64

with the same kernel.

This seems to be a regression in docker (I did a downgrade of docker, it solves this "issue").

Regards,

Comment 3 Antonio Murdaca 2018-02-11 15:14:50 UTC
This is not an issue. Very likely we back ported RT-kernel feature and that's just saying that your kernel doesn't support Real Time features. The warning is innocuous


Note You need to log in before you can comment on or make changes to this bug.