Bug 154418 - Make early-login work with firstboot
Make early-login work with firstboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks: FC4Target 154413
  Show dependency treegraph
 
Reported: 2005-04-11 12:13 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 13:22:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
firstboot-1.3.39-early-login.patch (1.12 KB, patch)
2005-04-14 12:39 EDT, Matthias Clasen
no flags Details | Diff
the initscript (1.29 KB, text/plain)
2005-04-14 15:23 EDT, Matthias Clasen
no flags Details

  None (edit)
Description Matthias Clasen 2005-04-11 12:13:22 EDT
Firstboot needs an X server. Two possible fixes are

- cheat and don't do early-login on the first boot, by looking at 
  the stamp file which firstboot uses for that purpose.

- make firstboot start an X server
Comment 1 Matthias Clasen 2005-04-14 12:37:33 EDT
It turns out that firstboot already contains code to start an X server, it just
needs some little fixes, and then firstboot can just be moved earlier in the
boot sequence. 
Comment 2 Matthias Clasen 2005-04-14 12:39:13 EDT
Created attachment 113164 [details]
firstboot-1.3.39-early-login.patch
Comment 3 Matthias Clasen 2005-04-14 15:21:13 EDT
Ok, scratch that. Firstboot needs network.
Here is a modified gdm-early-login initscript which simply bails out if it finds
that firstboot will run.
Comment 4 Matthias Clasen 2005-04-14 15:23:24 EDT
Created attachment 113181 [details]
the initscript
Comment 5 Matthias Clasen 2005-04-15 13:22:58 EDT
Should be fixed in gdm-2.6.0.8-4.

Note You need to log in before you can comment on or make changes to this bug.