Bug 1544344 - Storage Volume Status problem
Summary: Storage Volume Status problem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.10.0
Assignee: Sam Lucidi
QA Contact: Danylo Kholodov
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-12 08:31 UTC by Nikhil Dhandre
Modified: 2019-02-07 23:01 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-07 23:01:05 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)
observations (753.38 KB, image/gif)
2018-02-12 08:31 UTC, Nikhil Dhandre
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:0212 None None None 2019-02-07 23:01:10 UTC

Description Nikhil Dhandre 2018-02-12 08:31:03 UTC
Created attachment 1394814 [details]
observations

Description of problem:
-----------------------
I attached one newly created volume to an instance. Status found 'in-used' as well in Detail page attached instance count 1. I tried to detach instance, got a proper notification that instance detached. after refresh manager on All page status 'available' but on Detail page found attached instance count 1.

In such condition, I found:

1. Detail page 'Detach this cloud volume from an instance'is disabled due to volume status 'in-use'

2. controversial thing is All page allow me to detach instance. When I tried to detach instance > 'Unexpected Error'. 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
Version 5.9.0.20.20180206200727_d1873b9


How reproducible:
-----------------
always

Steps to Reproduce:
-------------------
1. Create new storage volume and attached to instance
2. Detached instance
3. Refresh manager and wait for All page status change to 'available'


Actual results:
---------------
- Detail page showing instance attached count > 0. but All page status showing 'available'
 
- Due to this All page allows detaching instance but Detail page option disabled.

Expected results:
-----------------
There should be sync and above problem should not come to the user. 

Additional info:
----------------

Attaching my observation output file.

Comment 11 Jad Haj Yahya 2018-11-13 12:36:54 UTC
Verified on 5.10.0.23

Comment 12 errata-xmlrpc 2019-02-07 23:01:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:0212


Note You need to log in before you can comment on or make changes to this bug.