Bug 1544410 - Failed to run cinder commands (os_domain_id AttributeError)
Summary: Failed to run cinder commands (os_domain_id AttributeError)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cinderclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Eric Harney
QA Contact: Avi Avraham
Kim Nylander
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-12 12:12 UTC by lkuchlan
Modified: 2018-06-27 13:45 UTC (History)
4 users (show)

Fixed In Version: python-cinderclient-3.5.0-0.20180211213738.1de605c.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:44:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1734945 None None None 2018-02-12 14:28:40 UTC
OpenStack gerrit 532217 None master: MERGED python-cinderclient: Migrate to keystoneauth identity cli opts. (I3c5141eeddd3747ff542e95b04e4848470ad9508) 2018-02-19 16:34:08 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:45:18 UTC

Description lkuchlan 2018-02-12 12:12:03 UTC
Description of problem:
Failed to run cinder commands

Version-Release number of selected component (if applicable):
puppet-cinder-12.2.0-0.20180123011607.277828c.el7ost.noarch
python2-cinderclient-3.4.0-0.20180110044822.36a2f4b.el7ost.noarch

How reproducible:
100%


Steps to Reproduce:
1. Deploy RHOS 13
2. source overcloudrc
3. Run cinder command 

Actual results:
(overcloud) [stack@undercloud-0 ~]$ cinder list
ERROR: 'Namespace' object has no attribute 'os_domain_id'


Additional information:

Overcloudrc parameters:
----------------------
(overcloud) [stack@undercloud-0 ~]$ cat overcloudrc 
# Clear any old environment that may conflict.
for key in $( set | awk '{FS="="}  /^OS_/ {print $1}' ); do unset $key ; done
export OS_NO_CACHE=True
export COMPUTE_API_VERSION=1.1
export OS_USERNAME=admin
export no_proxy=,10.0.0.103,192.168.24.11
export OS_USER_DOMAIN_NAME=Default
export OS_VOLUME_API_VERSION=3
export OS_CLOUDNAME=overcloud
export OS_AUTH_URL=http://10.0.0.103:5000//v3
export NOVA_VERSION=1.1
export OS_IMAGE_API_VERSION=2
export OS_PASSWORD=jhH7C8BzqsYbBpnadXmv4xCh2
export OS_PROJECT_DOMAIN_NAME=Default
export OS_IDENTITY_API_VERSION=3
export OS_PROJECT_NAME=admin
export OS_AUTH_TYPE=password
export PYTHONWARNINGS="ignore:Certificate has no, ignore:A true SSLContext object is not available"

# Add OS_CLOUDNAME to PS1
if [ -z "${CLOUDPROMPT_ENABLED:-}" ]; then
    export PS1=${PS1:-""}
    export PS1=\${OS_CLOUDNAME:+"(\$OS_CLOUDNAME)"}\ $PS1
    export CLOUDPROMPT_ENABLED=1
fi

Comment 1 Eric Harney 2018-02-12 14:29:53 UTC
We should resolve this by updating to cinderclient 3.5.0.

Comment 2 Eric Harney 2018-02-12 14:31:22 UTC
3.5.0 is already in queens-rdo.

Comment 4 Eric Harney 2018-02-12 14:39:02 UTC
Workaround: "unset OS_AUTH_TYPE" in your shell.

Comment 9 lkuchlan 2018-03-19 11:59:27 UTC
Tested using:
python2-cinderclient-3.5.0-0.20180211213738.1de605c.el7ost.noarch

Comment 11 errata-xmlrpc 2018-06-27 13:44:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.