Bug 1544601 - Cannot upgrade qt5-qtbase because of fcitx-qt5
Summary: Cannot upgrade qt5-qtbase because of fcitx-qt5
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fcitx-qt5   
(Show other bugs)
Version: 27
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Robin Lee
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1546706 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-13 02:41 UTC by Daniel
Modified: 2018-02-23 02:35 UTC (History)
3 users (show)

Fixed In Version: fcitx-qt5-1.2.2-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-22 14:53:48 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel 2018-02-13 02:41:35 UTC
Description of problem:
Cannot upgrade qt5-qtbase because of fcitx-qt5

Version-Release number of selected component (if applicable):
$ rpm -q fcitx-qt5
fcitx-qt5-1.2.1-1.fc27.x86_64
$ rpm -q qt5-qtbase
qt5-qtbase-5.9.2-6.fc27.x86_64


How reproducible:
Everytime

Steps to Reproduce:
1. Run "sudo dnf update"
2.
3.

Actual results:
$ sudo dnf update
[sudo] password for daniel: 
Contacting OpenClient Router for restricted repository information
Added restricted repo: Fedora-27-x86_64-Licensed
Last metadata expiration check: 1:18:53 ago on Tue 13 Feb 2018 10:11:43 AM JST.
Dependencies resolved.

 Problem 1: cannot install both qt5-qtbase-5.9.4-1.fc27.x86_64 and qt5-qtbase-5.9.2-6.fc27.x86_64
  - package fcitx-qt5-1.2.1-1.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.2, but none of the providers can be installed
  - cannot install the best update candidate for package qt5-qtbase-5.9.2-6.fc27.x86_64
  - cannot install the best update candidate for package fcitx-qt5-1.2.1-1.fc27.x86_64
 Problem 2: package fcitx-libpinyin-0.5.3-1.fc27.x86_64 requires libFcitxQt5DBusAddons.so.1()(64bit), but none of the providers can be installed
  - package fcitx-qt5-1.2.1-1.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.2, but none of the providers can be installed
  - package fcitx-qt5-1.1.1-1.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.1, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.9.4-1.fc27.x86_64 and qt5-qtbase-5.9.2-6.fc27.x86_64
  - cannot install both qt5-qtbase-5.9.1-9.fc27.x86_64 and qt5-qtbase-5.9.4-1.fc27.x86_64
  - package calibre-3.12.0-2.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.4, but none of the providers can be installed
  - cannot install the best update candidate for package fcitx-libpinyin-0.5.3-1.fc27.x86_64
  - cannot install the best update candidate for package calibre-3.12.0-1.fc27.x86_64
 Problem 3: problem with installed package fcitx-qt5-1.2.1-1.fc27.x86_64
  - package fcitx-qt5-1.2.1-1.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.2, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.9.4-1.fc27.x86_64 and qt5-qtbase-5.9.2-6.fc27.x86_64
  - package kf5-frameworkintegration-5.42.0-2.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.4, but none of the providers can be installed
  - cannot install the best update candidate for package kf5-frameworkintegration-5.42.0-1.fc27.x86_64
 Problem 4: problem with installed package fcitx-libpinyin-0.5.3-1.fc27.x86_64
  - package fcitx-libpinyin-0.5.3-1.fc27.x86_64 requires libFcitxQt5DBusAddons.so.1()(64bit), but none of the providers can be installed
  - package fcitx-qt5-1.2.1-1.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.2, but none of the providers can be installed
  - package fcitx-qt5-1.1.1-1.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.1, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.9.4-1.fc27.x86_64 and qt5-qtbase-5.9.2-6.fc27.x86_64
  - cannot install both qt5-qtbase-5.9.1-9.fc27.x86_64 and qt5-qtbase-5.9.4-1.fc27.x86_64
  - package kf5-kdeclarative-5.42.0-2.fc27.x86_64 requires qt5-qtbase(x86-64) = 5.9.4, but none of the providers can be installed
  - cannot install the best update candidate for package kf5-kdeclarative-5.42.0-1.fc27.x86_64
================================================================================
 Package                      Arch       Version              Repository   Size
================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 qt5-qtbase                   x86_64     5.9.1-9.fc27         fedora      3.4 M
 qt5-qtbase                   x86_64     5.9.4-1.fc27         updates     3.4 M
Skipping packages with broken dependencies:
 calibre                      x86_64     3.12.0-2.fc27        updates      29 M
 fcitx-qt5                    x86_64     1.1.1-1.fc27         fedora      123 k
 kf5-frameworkintegration     x86_64     5.42.0-2.fc27        updates     1.6 M
 kf5-kdeclarative             x86_64     5.42.0-2.fc27        updates     277 k

Transaction Summary
================================================================================
Skip  6 Packages

Nothing to do.
Complete!


Expected results:
New package of fcitx-qt5 should be provided to upgrade qt5-qtbase.

Additional info:

Comment 1 Fedora Update System 2018-02-13 17:18:47 UTC
fcitx-qt5-1.2.2-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-dec2208224

Comment 2 Fedora Update System 2018-02-14 18:27:04 UTC
fcitx-qt5-1.2.2-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-dec2208224

Comment 3 Robin Lee 2018-02-19 15:13:49 UTC
*** Bug 1546706 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2018-02-22 14:53:48 UTC
fcitx-qt5-1.2.2-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Daniel 2018-02-23 02:35:38 UTC
I upgraded fcitx-qt5-1.2.2-3.fc27 and everything worked fine for me.
Thanks a lot for your response.


Note You need to log in before you can comment on or make changes to this bug.