Bug 1544643 - [Tracker] RHCS 3.0.1 Release Notes
Summary: [Tracker] RHCS 3.0.1 Release Notes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Documentation
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 3.0
Assignee: Aron Gunn
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On: 1540845 1544720 1544808 1549293 1552210 1552699
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-13 06:29 UTC by Anjana Suparna Sriram
Modified: 2018-05-23 08:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-23 08:51:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Anjana Suparna Sriram 2018-02-13 06:29:08 UTC
This tracker bug is not a tracker just for known issues but for every change that should appear in the Release Notes - major updates, technical previews, deprecated functions, and so on.

If there is a change that does not have a separate bug (for example it is a change introduced in a rebase), add that rebase bug as a blocker and specify the nature of the change in the doc text field of that bug.

**How to let us know that a bug should be documented in the Release Notes**

1) Add the BZ number of the bug that needs to be documented to the "Depends On" field in the Release Notes tracker bug. Alternatively, add the tracker bug BZ number to the "Blocks" field in the bug that needs to be documented.

2) In the bug that needs to be documented, set the doctype to one of the following:

* bug fix - for notable bug fixes that have significant impact on customers

* enhancement - for new features and major enhancements, RFE bugs

* technology preview - for new features shipped as tech previews

* known issues - for the known issues found in this release

3) In the bug that needs to be documented, fill in the Doc Text field with the initial information. Use the template that is in the field.

----

**Candidates for inclusion**

* Bugs with a customer case attached

* Major new features and enhancements

* Bugs with significant impact on users

* Urgent or high priority bugs

* Fixed known issues

----

**How a good initial description looks like**

* Use the cause-consequence-fix-result (CCFR) format for bug fixes:

  Cause – what user action or circumstances trigger this bug 
    
  Consequence – what the user experiences when the bug occurs 
   
  Fix – what has been changed to fix the bug (overly technical details are not necessary)
    
  Result – what happens now with the fix applied

* Use the feature-reason-result (FFR) format for major updates:

    Feature – describes the enhancement from the user's point of view
    
    Reason – why was the enhancement implemented
    
    Result – what is the current user experience (may also be compared to the previous user experience)

----

**I want to document a change that does not have bug - how to do it?**

Add a comment here, we will add that description manually.

Comment 6 Vasishta 2018-03-05 11:56:15 UTC
Hi Aron,

Bug 1518788 has been fixed, VERIFIED and doc text has been updated as I observe. Can you please update th release notes by moving it from Known issue to Bug fix ?

Regards,
Vasishta Shastry

Comment 7 Vasishta 2018-03-05 15:17:19 UTC
Hi Aron, 

Can you please add Bug fix details of Bug 1546834 to release notes ?
Moving back to ASSIGNED stated.

Regards,
Vasishta Shastry
AQE, Ceph


Note You need to log in before you can comment on or make changes to this bug.