Bug 1544651 - Connectivity from an instance without Floating IP to an external IP fails
Summary: Connectivity from an instance without Floating IP to an external IP fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Aswin Suryanarayanan
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-13 07:33 UTC by Itzik Brown
Modified: 2018-10-18 07:19 UTC (History)
2 users (show)

Fixed In Version: opendaylight-8.0.0-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2018-06-27 13:44:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenDaylight Bug NETVIRT-1008 None None None 2018-02-13 07:33:38 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:45:18 UTC

Description Itzik Brown 2018-02-13 07:33:39 UTC
Description of problem:

In conntrack SNAT when an NAPT switch is selected on a compute without any port in the router subnet not all necessary fob flows are programmed which cause the connectivity from an instance without an IP to external network to fail.

Version-Release number of selected component (if applicable):
opendaylight-6.2.0-5.el7ost.noarch

How reproducible:


Steps to Reproduce:

1)Create an external network and external subnet.
2)Create a router and and set the g/w( NAPT switch should be selected on a compute without any router subnet)
3)Create an internal subnet and add to the router.

Actual results:


Expected results:


Additional info:

Comment 1 Aswin Suryanarayanan 2018-02-13 08:48:46 UTC
The SNAT flows addition fails in a switch which has no ports since there is race between tunnel creation and SNAT flow insertion. Since the compute have ports the tunnel creation happens when the pseudo port is added to the compute as a part of the tunnel creation. This  issue will be solved when netvirt move to genius auto tunnel creation.

Once the patches for https://jira.opendaylight.org/browse/NETVIRT-1009 is merged this bug should be resolved.

Comment 4 Aswin Suryanarayanan 2018-02-27 15:40:09 UTC
The patches for  https://jira.opendaylight.org/browse/NETVIRT-1009  is merged upstream.

Comment 6 Itzik Brown 2018-03-18 11:29:38 UTC
Verified with
opendaylight-8.0.0-2.el7ost.noarch

Comment 8 errata-xmlrpc 2018-06-27 13:44:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.