Bug 1544961 - libgfrpc does not export IPv6 RPC methods even with --with-ipv6-default
Summary: libgfrpc does not export IPv6 RPC methods even with --with-ipv6-default
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rpc
Version: mainline
Hardware: All
OS: Linux
high
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1545724
TreeView+ depends on / blocked
 
Reported: 2018-02-13 21:16 UTC by Sheena Artrip
Modified: 2018-06-20 17:59 UTC (History)
2 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1545724 (view as bug list)
Environment:
Last Closed: 2018-02-26 15:21:42 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sheena Artrip 2018-02-13 21:16:10 UTC
Description of problem:

Methods rpcsvc_program_register_rpcbind6/rpcsvc_program_unregister_rpcbind6 do not get exported with the symbol table when compiling --with-ipv6-default.

Version-Release number of selected component (if applicable): 

4.0, mainline

How reproducible:

Always

Steps to Reproduce:
1. Compile gluster with --with-ipv6-default. 
2. Check exported symbols of libgfrpc.so, see no rpcbind6

1. Compile gluster with --with-ipv6-default, --with-gnfs 
2. Run gluster
3. See nfs daemon crash with unable to lookup symbol rpcsvc_program_register_rpcbind6

Actual results:

libgfrpc does not have rpcbind6. gnfsd crashes with symbol import error.

nm -D /usr/lib64/libgfrpc.so -l | grep rpcbind6; echo $? => 1

nfs.log:

[2018-02-13 21:08:27.351949] W [MSGID: 101095] [xlator.c:433:xlator_dynload] 0-xlator: /usr/lib64/glusterfs/3.8dev/xlator/nfs/server.so: undefined symbol: rpcsvc_program_register_rpcbind6


Expected results:

libgfrpc has rpcbind6. gnfsd runs and listens ipv6 address.

nm -D /usr/lib64/libgfrpc.so -l | grep rpcbind6; echo $? => 0

Additional info:

Bug introduced when file rpc-lib/src/libgfrpc.sym was introduced. fix simple, incoming.

Comment 1 Worker Ant 2018-02-13 23:05:52 UTC
REVIEW: https://review.gluster.org/19563 (rpc: Adds rpcbind6 programs to libgfrpc symbols) posted (#1) for review on master by

Comment 2 Worker Ant 2018-02-14 15:48:08 UTC
COMMIT: https://review.gluster.org/19563 committed in master by  with a commit message- rpc: Adds rpcbind6 programs to libgfrpc symbols

Building with --with-default-ipv6 causes shared
components of gluster calling the rpcbind6 functions
to fail. Adding the symbols in the list is all that is
necessary. Building without ipv6 keeps the same behavior.

No test cases as this is a build-specific fix.

Change-Id: I248d3291bf17326b07d152d9b79cdcfaf9068f0d
BUG: 1544961
Signed-off-by: Sheena Artrip <sheenobu@fb.com>

Comment 3 Worker Ant 2018-02-15 14:20:24 UTC
REVIEW: https://review.gluster.org/19573 (rpc: Adds rpcbind6 programs to libgfrpc symbols) posted (#1) for review on release-4.0 by Kaleb KEITHLEY

Comment 4 Worker Ant 2018-02-15 14:34:52 UTC
REVISION POSTED: https://review.gluster.org/19573 (rpc: Adds rpcbind6 programs to libgfrpc symbols) posted (#2) for review on release-4.0 by Kaleb KEITHLEY

Comment 5 Shyamsundar 2018-06-20 17:59:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.