Bug 1545098 - SELinux prevents abrt-handle-upload from searching in /etc/pki directory
Summary: SELinux prevents abrt-handle-upload from searching in /etc/pki directory
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.5
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-14 10:21 UTC by Martin Kyral
Modified: 2018-10-30 10:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:02:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:03:21 UTC

Description Martin Kyral 2018-02-14 10:21:38 UTC
Description of problem:
The ABRT upstream test 'upload-handling' triggers the following AVC:

time->Tue Feb 13 13:55:31 2018
type=PROCTITLE msg=audit(1518526531.742:521): proctitle=2F7573722F62696E2F707974686F6E002D75002F7573722F62696E2F616272742D68616E646C652D75706C6F6164002F7661722F73706F6F6C2F61627274002F7661722F73706F6F6C2F616272742D75706C6F61642F0075706C6F61642E7461722E677A
type=SYSCALL msg=audit(1518526531.742:521): arch=c000003e syscall=2 success=no exit=-13 a0=7efd4711a622 a1=0 a2=1b6 a3=24 items=0 ppid=31886 pid=32010 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrt-handle-upl" exe="/usr/bin/python2.7" subj=system_u:system_r:abrt_upload_watch_t:s0 key=(null)
type=AVC msg=audit(1518526531.742:521): avc:  denied  { search } for  pid=32010 comm="abrt-handle-upl" name="pki" dev="dm-0" ino=33578472 scontext=system_u:system_r:abrt_upload_watch_t:s0 tcontext=system_u:object_r:cert_t:s0 tclass=dir


Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-189.el7

How reproducible:


Steps to Reproduce:
1. run the mentioned test
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Milos Malik 2018-02-14 10:46:30 UTC
The only SELinux denial triggered in enforcing mode is:
----
type=PROCTITLE msg=audit(02/14/2018 05:44:11.430:837) : proctitle=/usr/bin/python -u /usr/bin/abrt-handle-upload /var/spool/abrt /var/spool/abrt-upload/ upload.tar.gz 
type=SYSCALL msg=audit(02/14/2018 05:44:11.430:837) : arch=x86_64 syscall=open success=no exit=EACCES(Permission denied) a0=0x7f80d4cb0622 a1=O_RDONLY a2=0x1b6 a3=0x24 items=0 ppid=25389 pid=25476 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=abrt-handle-upl exe=/usr/bin/python2.7 subj=system_u:system_r:abrt_upload_watch_t:s0 key=(null) 
type=AVC msg=audit(02/14/2018 05:44:11.430:837) : avc:  denied  { search } for  pid=25476 comm=abrt-handle-upl name=pki dev="vda1" ino=6291570 scontext=system_u:system_r:abrt_upload_watch_t:s0 tcontext=system_u:object_r:cert_t:s0 tclass=dir 
----

The TC does not produce any SELinux denials in permissive mode.

Comment 5 errata-xmlrpc 2018-10-30 10:02:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.