Bug 1545136 - [RFE] foreman_maintain should not allow upgrades of self-registered Satellites
Summary: [RFE] foreman_maintain should not allow upgrades of self-registered Satellites
Keywords:
Status: CLOSED DUPLICATE of bug 1544769
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: Anurag Patel
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-14 10:49 UTC by Rich Jerrido
Modified: 2018-02-14 11:17 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-14 11:17:31 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rich Jerrido 2018-02-14 10:49:57 UTC
Description of problem:

With the deprecation of support for self-registered Satellites in Satellite 6.3 (see https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3-beta/html-single/installation_guide/#system_requirements), I would like to request that foreman_admin doesn't allow end-users to upgrade systems that are self-registered. 

Currently today we warn them (https://github.com/theforeman/foreman_maintain/blob/master/definitions/checks/system_registration.rb).

Comment 1 Swapnil Abnave 2018-02-14 11:17:31 UTC

*** This bug has been marked as a duplicate of bug 1544769 ***


Note You need to log in before you can comment on or make changes to this bug.