Bug 1545256 - gmt cannot find gshhg files
Summary: gmt cannot find gshhg files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: GMT
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-14 13:35 UTC by Patrick Stanistreet
Modified: 2019-03-05 15:20 UTC (History)
2 users (show)

Fixed In Version: GMT-5.4.3-1.fc27 GMT-5.4.3-1.fc26 GMT-5.4.3-1.el7 GMT-5.4.4-3.fc27 GMT-5.4.4-3.fc28 GMT-5.4.4-3.fc29 GMT-5.4.4-3.el7 GMT-5.4.5-2.fc28 GMT-5.4.5-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-22 22:29:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Patrick Stanistreet 2018-02-14 13:35:09 UTC
Description of problem:
installed   GMT,dcw-gmt, gshhg-gmt-nc4  and run script
to render map.


Version-Release number of selected component (if applicable):
GMT.x86_64       5.4.2-3.fc27   fedora

How reproducible:


gmt pscoast -Vd -Dh  -R-90/-70/0/20 -JM6i -P -B5g5 -Gchocolate > map-test.ps 

Steps to Reproduce:
1.  
2.
3.

Actual results:
pscoast: GSHHG version 2.2.0 or newer is needed to use coastlines with GMT.
	Get and install GSHHG from ftp://ftp.soest.hawaii.edu/gshhg/.
pscoast: Could not find file [GSHHG low resolution shorelines]
pscoast: No GSHHG databases available - must abort


Expected results:

create the map

Additional info:

may try to compile GMT from source as GSHHGDIR  never finds the
actual directories.   /usr/share/gshhg-gmt-nc4/

Comment 1 Patrick Stanistreet 2018-02-20 22:45:55 UTC
I did  compile GMT from source.   

I had to edit the cmake/ConfigUser.cmake       
 and set the path for the map files before running cmake

now I can use GMT.

Comment 2 Fedora Update System 2018-02-22 04:58:42 UTC
GMT-5.4.3-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-963449b420

Comment 3 Fedora Update System 2018-02-22 04:58:54 UTC
GMT-5.4.3-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-39a5c47e98

Comment 4 Fedora Update System 2018-02-22 04:59:02 UTC
GMT-5.4.3-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-0c8e266959

Comment 5 Fedora Update System 2018-02-22 15:28:46 UTC
GMT-5.4.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-39a5c47e98

Comment 6 Fedora Update System 2018-02-22 15:31:07 UTC
GMT-5.4.3-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-0c8e266959

Comment 7 Fedora Update System 2018-02-22 16:04:42 UTC
GMT-5.4.3-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-963449b420

Comment 8 Fedora Update System 2018-03-06 17:22:11 UTC
GMT-5.4.3-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2018-03-06 17:28:59 UTC
GMT-5.4.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2018-03-13 17:07:16 UTC
GMT-5.4.3-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Patrick Stanistreet 2018-04-23 17:06:06 UTC
dnf list gshhg-gmt-nc4  gmt
Last metadata expiration check: 0:27:59 ago on Mon 23 Apr 2018 09:33:52 AM PDT.
Installed Packages
GMT.x86_64                              5.4.2-4.fc28                     @fedora
gshhg-gmt-nc4.noarch                    2.3.3-6.fc28                     @fedora
Available Packages
GMT.i686                                5.4.2-4.fc28                     fedora 


these are the latest packages from f28 beta  but the same errors
continue

Comment 12 Andrew Clegg 2018-10-11 08:42:20 UTC
dnf list gshhg-gmt-nc4  gmt
Last metadata expiration check: 7 days, 23:13:03 ago on Wed 03 Oct 2018 10:27:51 BST.
Installed Packages
GMT.x86_64                                           5.4.2-4.fc28                                 @fedora
gshhg-gmt-nc4.noarch                                 2.3.3-6.fc28                                 @fedora
Available Packages
GMT.i686                                             5.4.2-4.fc28                                 fedora 


This is still the case in Fedora 28 as released.

gmt gmtset DIR_GSHHG /usr/share/gshhg-gmt-nc4

can be used as a workaround

Comment 13 Orion Poplawski 2018-10-11 21:10:59 UTC
This should be fixed in a coming update.  Though since you are asking for high resolution coastlines you will also need to install gshhg-gmt-nc4-high.

Comment 14 Fedora Update System 2018-10-11 21:55:54 UTC
GMT-5.4.4-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-b299d8284b

Comment 15 Fedora Update System 2018-10-11 21:56:03 UTC
GMT-5.4.4-3.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-3da20bbe80

Comment 16 Fedora Update System 2018-10-11 21:56:11 UTC
GMT-5.4.4-3.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-4b312a0439

Comment 17 Fedora Update System 2018-10-11 21:56:20 UTC
GMT-5.4.4-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-df455a3263

Comment 18 Fedora Update System 2018-10-12 18:25:49 UTC
GMT-5.4.4-3.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-3da20bbe80

Comment 19 Fedora Update System 2018-10-12 20:54:02 UTC
GMT-5.4.4-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-df455a3263

Comment 20 Fedora Update System 2018-10-12 21:05:30 UTC
GMT-5.4.4-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-b299d8284b

Comment 21 Fedora Update System 2018-10-12 21:27:53 UTC
GMT-5.4.4-3.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-4b312a0439

Comment 22 Fedora Update System 2018-10-22 22:29:27 UTC
GMT-5.4.4-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2018-10-22 22:58:31 UTC
GMT-5.4.4-3.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2018-10-30 17:25:54 UTC
GMT-5.4.4-3.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2019-02-24 18:50:13 UTC
GMT-5.4.5-2.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-e1acf50e8d

Comment 26 Fedora Update System 2019-02-24 18:50:19 UTC
GMT-5.4.5-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-c987a82057

Comment 27 Fedora Update System 2019-02-25 01:20:11 UTC
GMT-5.4.5-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-c987a82057

Comment 28 Fedora Update System 2019-02-25 02:31:41 UTC
GMT-5.4.4-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2019-02-25 03:15:17 UTC
GMT-5.4.5-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-e1acf50e8d

Comment 30 Fedora Update System 2019-03-05 04:44:58 UTC
GMT-5.4.5-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 31 Fedora Update System 2019-03-05 15:20:56 UTC
GMT-5.4.5-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.