Bug 1545586 - unbound start causes avc denial
Summary: unbound start causes avc denial
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-15 10:19 UTC by Petr Sklenar
Modified: 2018-10-30 10:03 UTC (History)
5 users (show)

Fixed In Version: selinux-policy-3.13.1-197.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:02:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:03:21 UTC

Description Petr Sklenar 2018-02-15 10:19:03 UTC
Description of problem:
unbound start caused avc denial

Version-Release number of selected component (if applicable):
unbound-1.6.6-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. start unbound


Actual results:
type=PROCTITLE msg=audit(02/15/2018 05:15:30.047:435) : proctitle=/usr/sbin/unbound -d
type=SYSCALL msg=audit(02/15/2018 05:15:30.047:435) : arch=x86_64 syscall=setsockopt success=yes exit=0 a0=0x13 a1=ip a2=IP_TRANSPARENT a3=0x7ffe51a3d284 items=0 ppid=1 pid=10592 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=unbound exe=/usr/sbin/unbound subj=system_u:system_r:named_t:s0 key=(null)
type=AVC msg=audit(02/15/2018 05:15:30.047:435) : avc:  denied  { net_raw } for  pid=10592 comm=unbound capability=net_raw  scontext=system_u:system_r:named_t:s0 tcontext=system_u:system_r:named_t:s0 tclass=capability
----
type=PROCTITLE msg=audit(02/15/2018 05:15:30.047:436) : proctitle=/usr/sbin/unbound -d
type=SYSCALL msg=audit(02/15/2018 05:15:30.047:436) : arch=x86_64 syscall=setsockopt success=yes exit=0 a0=0x14 a1=ip a2=IP_TRANSPARENT a3=0x7ffe51a3d284 items=0 ppid=1 pid=10592 auid=unset uid=root gid=root euid=root suid=root fsuid=root egid=root sgid=root fsgid=root tty=(none) ses=unset comm=unbound exe=/usr/sbin/unbound subj=system_u:system_r:named_t:s0 key=(null)
type=AVC msg=audit(02/15/2018 05:15:30.047:436) : avc:  denied  { net_raw } for  pid=10592 comm=unbound capability=net_raw  scontext=system_u:system_r:named_t:s0 tcontext=system_u:system_r:named_t:s0 tclass=capability
[ INFO  ] What to do next?


Expected results:


Additional info:

Comment 6 errata-xmlrpc 2018-10-30 10:02:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.