Bug 1545713 - Request periodic scans while WiFi list is open
Request periodic scans while WiFi list is open
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: control-center (Show other bugs)
7.5
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Bastien Nocera
Desktop QE
Jana Heves
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2018-02-15 09:14 EST by Oliver Haessler
Modified: 2018-05-17 10:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: control-center-3.26.2-8.el7
Doc Type: Known Issue
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 09:11:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 767918 None None None 2018-02-20 07:36 EST
GNOME Bugzilla 793238 None None None 2018-02-20 07:32 EST
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 09:12 EDT

  None (edit)
Description Oliver Haessler 2018-02-15 09:14:09 EST
Description of problem:
In RHEL 7.5 Snapshot 3, if the Gnome control center is opened on the WiFi Tab, and stays there, the list of available networks is not shown after some time, and on the current connected wifi network is shown.

------
based on https://bugzilla.gnome.org/show_bug.cgi?id=767918

NM upstream would like to reduce periodic scanning, and that means that clients should start implementing scan requests themselves while their wifi lists are open if they use that model.  Similar to how the Windows and macOS WiFi lists update themselves when they are open.

Once enough clients have been updated (eg, nm-applet, gnome-shell, KDE, geoclue, etc) we can reduce periodic scanning in NM itself.
------

This needs to be added also to Gnome control center.

Please make sure this is included into RHEL 7.5, as it impacts users trying to connect to Wifi networks.
Comment 2 Bastien Nocera 2018-02-20 10:20:26 EST
The requirement is new due to NetworkManager 1.10 being used which includes the following change:
* Background scanning is now disabled for non-WPA-Enterprise Wi-Fi networks.
Comment 4 Vladimir Benes 2018-02-20 10:32:31 EST
Could we at least scan when we open the Wifi panel? Isn't this doable for 7.5? It's really embarassing to turn off/on wifi to see available networks.
Comment 6 Whitney Chadwick 2018-02-20 12:41:31 EST
Set Blocker flag to + per request from tpelka
Comment 7 Bastien Nocera 2018-02-21 06:27:12 EST
Built in control-center-3.26.2-8.el7
Comment 8 Vladimir Benes 2018-02-21 06:37:46 EST
Working well, thanks!!
Comment 10 Tomas Pelka 2018-02-22 09:00:56 EST
OK I find out that for me it was caused by autoconnect. Autoconnect on RedHat (with always ask password) actually cause that no other networks are visible in the list. Filed another bz - https://bugzilla.redhat.com/show_bug.cgi?id=1548000
Comment 15 errata-xmlrpc 2018-04-10 09:11:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.