Bug 154584 - Needed sound card option not unmuted by default.
Needed sound card option not unmuted by default.
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Depends On:
  Show dependency treegraph
Reported: 2005-04-12 16:05 EDT by Christian Schaller
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-13 12:19:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
screenshot of the gnome-volume-control with the needed switch enabled (20.41 KB, image/png)
2005-04-13 08:50 EDT, Christian Schaller
no flags Details

  None (edit)
Description Christian Schaller 2005-04-12 16:05:24 EDT
I have a Dell Inspiron 8600 with a Intel 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M)
AC'97 Audio controler. It worked perfectly under FC3 apart from the umuting
pains described by other in 124497.

Under FC4 test system-config-soundcard seems to detect the card perfectly, but
no sound is actually played. looking at gnome-volume-control and alsamixer I can
see nothing wrong, all channels seems unmuted and set to something reasonable.

When playing back sound using XMMS or RB they play as if everything is ok, but
no actual sound.

Trying with my external USB soundcard I do get sound.

My modprobe.conf have the following lines:
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-intel8x0
Comment 1 Christian Schaller 2005-04-13 04:54:52 EDT
Tested using headphones today and got sound. So I guess the basic issue is that
with aumix neither gnome-volume-control or alsamixer lets me unmute the speakers
of my laptop for some reason.
Comment 2 Glenn O. Pringle 2005-04-13 06:17:33 EDT
I'm running on a Toshiba Satellite 2805-S201 with a Yamaha
Soundcard(YMF-754[DS-1E Audio Controller]). This setup was working without
issues under previous Fedora versions(last one I used was FC3T3).

Under FC4T2 I'm not able to get any sound.

When I try to run system-config-soundcard it's not able to detect the card.

Below is the output from dmesg:

application mixer_applet2 uses obsolete OSS audio interface

Comment 3 Mary Ellen Foster 2005-04-13 08:04:18 EDT
I had something similar on my Dell Inspiron 5160 (same sound card, I think). Are
you sure you enabled *everything* in alsamixer? I thought I had the first time I
tried, but when I tried again and turned on/up *everything* in alsamixer (make
sure you scroll all the way right) I started hearing sound.

On fedora-test-list, someone from Redhat suggested that it had been the
"Headphone Jack Sense" setting that did it.
Comment 4 Christian Schaller 2005-04-13 08:46:50 EDT
Thanks Mary, I tried once more due to you and unmuted the option called
'External amplifier' that gave me sound back. I guess this bug is that this
option did not get unmuted and set to something reasonable like the other
sliders. Will attach a screenshot showing the option. (how external amplifier is
related to internal speakers is another question for the hardware maker :)
Comment 5 Christian Schaller 2005-04-13 08:50:49 EDT
Created attachment 113090 [details]
screenshot of the gnome-volume-control with the needed switch enabled
Comment 6 Bastien Nocera 2005-04-13 12:19:39 EDT
Christian, if your soundcard needs the "External Amplifier" turned off by
default, then this means that there is a bug in the soundcard driver. You would
need to file a bug directly with ALSA (or against the kernel here, but you would
get a faster turn-around at ALSA's tracker).

See this bug for example:
Comment 7 Jonathan Blandford 2005-04-18 15:58:21 EDT
To add to this bug, I had to turn on both Headphone Jack Sense and Line Jack
Sense.  Both of these defaulted to the wrong value, and I don't get any sound if
either of them is off.  'External Amplifier' didn't modify anything.
Comment 8 Bastien Nocera 2005-04-19 05:35:57 EDT
Jonathan, same thing as above, this would need to be brought up to the ALSA
Comment 9 Ranju Mathew 2005-07-15 16:19:43 EDT
The following procedure worked for me.  This seems to happen using the
snd-intel8x0 module.
1.  unload all the snd modules:
          lsmod | grep snd | while read modules
            rmmod $modules
2.  reload snd module
          modprobe snd-intel8x0
3.  set your mixer.  I use aumix
Comment 10 CSM 2005-08-16 09:18:14 EDT
I'm using a Dell 5160 - Mary Ellen Foster's comment was right on for Fedora 4. 
If you don't know exactly where to turn everything on though it's under
Applicaitons --> Sound --> Volume Control.  Then select Edit --> Preferences
(fyi - volume control crashed the first time I selected this) and check
everything.  Then under the switches tab check External Amplifier and turn up
the volume on everything else till you get sound.  And it works!  Thanks for the
help all!

Note You need to log in before you can comment on or make changes to this bug.