Bug 1545842 - resolv.conf contains nameserver 192.168.122.1 on rhel7.5
Summary: resolv.conf contains nameserver 192.168.122.1 on rhel7.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-images
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Alex Schultz
QA Contact: Omri Hochman
URL:
Whiteboard:
: 1561688 (view as bug list)
Depends On:
Blocks: 1568151 1582083 1592575 1592576 1592577 1592578 1673164
TreeView+ depends on / blocked
 
Reported: 2018-02-15 16:45 UTC by Alex Schultz
Modified: 2019-02-06 19:55 UTC (History)
12 users (show)

Fixed In Version: rhosp-director-images-13.0-20180228.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1568151 1582083 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:24:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1749756 None None None 2018-02-15 17:32:02 UTC
OpenStack gerrit 545067 None MERGED Create element to purge resolv.conf 2020-06-11 14:28:12 UTC
OpenStack gerrit 545068 None MERGED Purge resolv.conf from the overcloud images 2020-06-11 14:28:12 UTC
Red Hat Product Errata RHEA-2018:2083 None None None 2018-06-27 13:26:04 UTC

Description Alex Schultz 2018-02-15 16:45:22 UTC
Problem:
There is a 5 second delay when sshing to overcloud nodes due to resolv.conf containing nameserver 192.168.122.1 which is not valid for the deployment. This can cause issues when deploying as it adds delays when trying to perform some deployment actions.

Cause:
This delay stems from a change to the way ifup-post was updated for RHEL7.5 in which the nameservers from the overcloud images are no longer being cleared out.

See https://bugzilla.redhat.com/show_bug.cgi?id=1543580#c15

Possible fix:
Remove nameserver 192.168.122.1 from the shipped overcloud images.

Comment 6 Emilien Macchi 2018-03-28 18:11:42 UTC
*** Bug 1561688 has been marked as a duplicate of this bug. ***

Comment 7 Uemit Seren 2018-04-16 15:00:59 UTC
This also affects OSP12 deployments. 
Will new overcloud images with clean resolve.conf be released for OSP12 ?

Comment 8 Alex Schultz 2018-04-16 20:48:29 UTC
It was backported upstream. I'll create a bug to check for 12.

Comment 9 Omri Hochman 2018-05-03 19:58:12 UTC
Unable to reproduce :
(undercloud) [stack@undercloud75 bm-upgrade-tests]$ rpm -qa | grep images
rhosp-director-images-ipa-13.0-20180426.1.el7ost.noarch
rhosp-director-images-13.0-20180426.1.el7ost.noarch

(undercloud) [stack@undercloud75 bm-upgrade-tests]$ ssh heat-admin@192.168.0.14
The authenticity of host '192.168.0.14 (192.168.0.14)' can't be established.
ECDSA key fingerprint is SHA256:8b5enYcxy5RBXUqROLPQRcW3WEGB45d/6LQQ31aBhUE.
ECDSA key fingerprint is MD5:95:b3:03:ed:84:46:fe:61:bf:77:72:2c:8e:af:a5:6c.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.0.14' (ECDSA) to the list of known hosts.
[heat-admin@overcloud-cephstorage-1 ~]$ sudo su -
[root@overcloud-cephstorage-1 ~]# cat /etc/resolv.conf
; Created by cloud-init on instance boot automatically, do not edit.
;
# Generated by NetworkManager
nameserver 10.16.36.29

Comment 10 Jon Schlueter 2018-05-03 19:59:34 UTC
manual sanity check verified


$ guestfish -a overcloud-full.qcow2 run : mount /dev/sda / : cat /etc/resolv.conf
# Generated by NetworkManager

for overcloud-full-13.0-20180502.1.x86_64

Comment 11 Sergii Mykhailushko 2018-06-14 14:06:30 UTC
We have '192.168.122.1' in resolv.conf in overcloud image for RHOSP 12:

~~~
[root@thinkpad ~]# guestfish --ro -a overcloud-full.qcow2 

Welcome to guestfish, the guest filesystem shell for
editing virtual machine filesystems and disk images.

Type: 'help' for help on commands
      'man' to read the manual
      'quit' to quit the shell

><fs> run
><fs> list-filesystems 
/dev/sda: xfs
><fs> mount-ro /dev/sda /
><fs> cat /etc/resolv.conf 
# Generated by NetworkManager
nameserver 192.168.122.1
~~~

Comment 12 Alex Schultz 2018-06-14 14:50:14 UTC
OSP12 is being tracked by https://bugzilla.redhat.com/show_bug.cgi?id=1568151

Comment 15 errata-xmlrpc 2018-06-27 13:24:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2083


Note You need to log in before you can comment on or make changes to this bug.