Bug 1545891 - Provide a automated way to update bugzilla status with patch merge.
Summary: Provide a automated way to update bugzilla status with patch merge.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-15 19:06 UTC by Amar Tumballi
Modified: 2018-06-20 18:00 UTC (History)
2 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 18:00:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amar Tumballi 2018-02-15 19:06:04 UTC
Description of problem:
Today, it is manual, causing the stress on community contribution.


Additional info:
Need automated way to handle these things, so project can have much easier method to handle bugs.

Comment 1 Niels de Vos 2018-02-16 14:16:38 UTC
Some work has been done, but was never finished/deployed:
- https://github.com/nandajavarma/gerrit-hooks

I hope those scripts can be used as a basis.

Comment 2 Worker Ant 2018-03-22 15:02:07 UTC
COMMIT: https://review.gluster.org/19564 committed in master by "Shyamsundar Ranganathan" <srangana@redhat.com> with a commit message- rfc.sh: provide a unified way to update bugs or github issues ID

Change-Id: Ie78d87b31512da6201ae26f3d391fa3f8e5b68d1
fixes: bz#1545891
Signed-off-by: Amar Tumballi <amarts@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:00:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.