Bug 1546103 - run-tests-in-vagrant.sh should return test status
Summary: run-tests-in-vagrant.sh should return test status
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-16 10:34 UTC by Niels de Vos
Modified: 2018-10-23 15:06 UTC (History)
3 users (show)

Fixed In Version: glusterfs-5.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-23 15:06:35 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Niels de Vos 2018-02-16 10:34:53 UTC
Description of problem:
The ./run-tests-in-vagrant.sh script does not return the correct exit
status. Even if the tests in the Vagrant VM fail, the script returns
success. This throws off the expectations that any regular testers (or 
CI) have.


Version-Release number of selected component (if applicable):
All

How reproducible:
100%

Steps to Reproduce:
1. run ./run-tests-in-vagrant.sh on the master branch

Actual results:
The current Vagrant VM is not correctly configured to run the geo-replication tests. This causes the regression-tests to fail, but the ./run-tests-in-vagrant.sh returns 0/SUCCESS.

Expected results:
A failure in the regression tests should cause the ./run-tests-in-vagrant.sh script to exit with an error.

Additional info:

Comment 1 Worker Ant 2018-02-16 10:36:29 UTC
REVIEW: https://review.gluster.org/19575 (tests: run-tests-in-vagrant.sh should return test status) posted (#1) for review on master by Niels de Vos

Comment 2 Worker Ant 2018-05-18 13:09:08 UTC
REVIEW: https://review.gluster.org/19575 (tests: run-tests-in-vagrant.sh should return test status) posted (#2) for review on master by Niels de Vos

Comment 3 Worker Ant 2018-05-28 02:52:45 UTC
COMMIT: https://review.gluster.org/19575 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- tests: run-tests-in-vagrant.sh should return test status

The ./run-tests-in-vagrant.sh script does not return the correct exit
status. Even if the tests in the Vagrant VM fail, the script returns
success. This throws off the expectations that any regular testers (or
CI) have.

BUG: 1546103
Change-Id: I7f00903f9fe4ef3be8ba80db0f9aa8d412502b86
Signed-off-by: Niels de Vos <ndevos@redhat.com>

Comment 4 Shyamsundar 2018-10-23 15:06:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-5.0, please open a new bug report.

glusterfs-5.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2018-October/000115.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.