Bug 1546128 - No clear error message when missing environment dependency
Summary: No clear error message when missing environment dependency
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-16 12:01 UTC by Julie Pichon
Modified: 2018-06-27 13:45 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-ui-8.3.1-0.20180303225336.57e3d96.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:44:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
There is now an error at the top (288.89 KB, image/png)
2018-04-05 22:26 UTC, Jason E. Rist
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 535324 None master: MERGED tripleo-ui: Fix EnvironmentConfiguration dialog (Ia056621a847b56913b1dfff57f6e8237f62bd8d7) 2018-03-21 13:37:37 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:45:38 UTC

Description Julie Pichon 2018-02-16 12:01:41 UTC
Description of problem:
It's difficult to understand why the 'Save' button is disabled, when accidentally selecting only one part of a dependent environment

Version-Release number of selected component (if applicable):
openstack-tripleo-ui-8.1.1-0.20180122135122.aef02d8.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Select "SSL-enabled deployment with DNS name as public endpoint" (and leave "SSL on OpenStack Public Endpoints" disabled)
2. Move to another tab
3. Try to save changes

Actual results:
4. Save button is disabled, with no information

Expected results:
4. A clear error message about what issue to look for is displayed

Additional info:
This is fixed upstream in https://review.openstack.org/#/c/535324/

Comment 7 Jason E. Rist 2018-04-05 22:26:10 UTC
Created attachment 1417920 [details]
There is now an error at the top

Comment 9 errata-xmlrpc 2018-06-27 13:44:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.