Bug 1546185 - Deployment should stop (fail) when pools creation fails (when deploying >= luminous)
Summary: Deployment should stop (fail) when pools creation fails (when deploying >= lu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: 3.2
Assignee: leseb
QA Contact: Yogev Rabl
URL:
Whiteboard:
: 1541070 (view as bug list)
Depends On:
Blocks: 1553640
TreeView+ depends on / blocked
 
Reported: 2018-02-16 14:29 UTC by Giulio Fidente
Modified: 2019-01-03 19:01 UTC (History)
14 users (show)

Fixed In Version: RHEL: ceph-ansible-3.1.0-0.1.beta4.el7cp Ubuntu: ceph-ansible_3.1.0~rc3-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:01:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 2432 None None None 2018-03-05 09:09:38 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:01:45 UTC

Description Giulio Fidente 2018-02-16 14:29:42 UTC
Description of problem:
When creating pools, the deployment does not stop if the pool create command returns non-zero.

From the Ceph luminous version the cluster will refuse to create a new pool if the requested additional PGs are too many (not enough PGs available), ceph-ansible should fail in that scenario instead of proceding with the deployment because it will miss completely the pools the user is demanding for.

Version-Release number of selected component (if applicable):
3.0.24

Comment 3 Giulio Fidente 2018-02-20 09:45:53 UTC
*** Bug 1541070 has been marked as a duplicate of this bug. ***

Comment 5 Ken Dreyer (Red Hat) 2018-03-16 22:54:39 UTC
https://github.com/ceph/ceph-ansible/pull/2432 is linked here. It is in ceph-ansible v3.1.0beta4 upstream.

Giulio, would you please confirm this feature is working as you expect in 3.1.0beta4?

Comment 14 Yogev Rabl 2018-12-15 03:22:22 UTC
verified

Comment 16 errata-xmlrpc 2019-01-03 19:01:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.