Bug 154621 - "pnmtopgm" handles transparency incorrectly when working with colormapped PNG
"pnmtopgm" handles transparency incorrectly when working with colormapped PNG
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-12 23:40 EDT by Robert Wilhite
Modified: 2013-07-02 19:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 11:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Wilhite 2005-04-12 23:40:04 EDT
Description of problem:
"pnmtopgm" handles transparency incorrectly when working with colormapped PNG

Version-Release number of selected component (if applicable):
netpbm-10.25-2

How reproducible:
fails predictably

Steps to Reproduce:
1. grab a PNG from the pixmaps directory
2. convert it to PNM
3. reduce the colors below 256 to enable colormap handling
4. use pnmtopng with -transparent option, so for example...

pngtopnm /usr/share/pixmaps/gnomemeeting-splash.png | pnmdepth 10 | pnmtopng
-trans white > /tmp/test4.png
  
Actual results:
white region of picture is not transparent

Expected results:
white region of picture should be transparent

Additional info:
1. Worked fine in FC2.
2. Run that pipeline above about 20 times; it will occasionally seg-fault.
3. If you leave the "pnmdepth 10" step out, then pnmtopng doesn't try to create
a colormapped image, and the transparency works correctly.
4. This is my first time reporting a bug, so I hope I don't totally suck.
Comment 1 Jindrich Novy 2005-04-14 11:11:48 EDT
I tried that with netpbm-10.26.4 and netpbm-10.27 and I see it works now. So
upgrading to the latest devel netpbm should solve your problem.
(the white colour is transparent in the /tmp/test4.png image)

Jindrich

Note You need to log in before you can comment on or make changes to this bug.