Bug 1546884 - Apply patches use python-gssapi instead of pykerberos or orphan package
Summary: Apply patches use python-gssapi instead of pykerberos or orphan package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: did
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Šplíchal
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/psss/did/pull/147
Whiteboard:
Depends On:
Blocks: 1537249
TreeView+ depends on / blocked
 
Reported: 2018-02-19 21:55 UTC by Robbie Harwood
Modified: 2018-03-05 22:00 UTC (History)
2 users (show)

Fixed In Version: did-0.9-7.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-05 22:00:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Robbie Harwood 2018-02-19 21:55:50 UTC
This bug has been created in accordance with https://fedoraproject.org/wiki/Changes/kerberos-in-python-modernization (tracking bug: rhbz#1537249 ).  In brief: pykerberos does not provide a good interface, and we would like to eventually remove it.

Patches to port to python-gssapi have been provided here for your convenience: https://github.com/psss/did/pull/147

Please be aware that this has a hard deadline of March 6 as per https://fedoraproject.org/wiki/Releases/28/Schedule so your prompt action is appreciated.

This package seems unmaintained upstream.  If that is the case, please consider orphaning it.

Comment 1 Fedora End Of Life 2018-02-20 15:31:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Comment 2 Robbie Harwood 2018-03-05 22:00:05 UTC
Patch has been applied; closing.


Note You need to log in before you can comment on or make changes to this bug.