Bug 1546954 - [Rebalance] "Migrate file failed: <filepath>: failed to get xattr [No data available]" warnings in rebalance logs
Summary: [Rebalance] "Migrate file failed: <filepath>: failed to get xattr [No data av...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Nithya Balachandran
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1546945 1548078 1548264
TreeView+ depends on / blocked
 
Reported: 2018-02-20 06:43 UTC by Nithya Balachandran
Modified: 2018-06-20 18:00 UTC (History)
4 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1546945
: 1548078 1548264 (view as bug list)
Environment:
Last Closed: 2018-06-20 18:00:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2018-02-20 06:43:57 UTC
+++ This bug was initially created as a clone of Bug #1546945 +++

Description of problem:
=======================
After rebalance is triggered on the volume, on few files I am seeing below warnings in rebalance logs,

[2018-02-20 05:35:39.439245] W [MSGID: 109023] [dht-rebalance.c:2036:dht_migrate_file] 0-distrepx3-dht: Migrate file failed:/1/linux-4.6.4/Documentation/devicetree/bindings/mfd/arizona.txt: failed to get xattr from distrepx3-replicate-2 [No data available]
[2018-02-20 05:35:39.699443] W [MSGID: 109023] [dht-rebalance.c:2036:dht_migrate_file] 0-distrepx3-dht: Migrate file failed:/1/linux-4.6.4/Documentation/devicetree/bindings/mfd/da9055.txt: failed to get xattr from distrepx3-replicate-2 [No data available]
[2018-02-20 05:35:40.056391] W [MSGID: 109023] [dht-rebalance.c:2036:dht_migrate_file] 0-distrepx3-dht: Migrate file failed:/1/linux-4.6.4/Documentation/devicetree/bindings/mfd/tps6507x.txt: failed to get xattr from distrepx3-replicate-2 [No data available]
[2018-02-20 05:35:42.952071] W [MSGID: 109023] [dht-rebalance.c:2036:dht_migrate_file] 0-distrepx3-dht: Migrate file failed:/1/linux-4.6.4/Documentation/devicetree/bindings/mmc/mmc-card.txt: failed to get xattr from distrepx3-replicate-2 [No data available]
[2018-02-20 05:35:43.019614] W [MSGID: 109023] [dht-rebalance.c:2036:dht_migrate_file] 0-distrepx3-dht: Migrate file failed:/1/linux-4.6.4/Documentation/devicetree/bindings/mmc/mmc-spi-slot.txt: failed to get xattr from distrepx3-replicate-0 [No data available]

I am seeing may such warnings in the rebalance logs and logs will get flooded with these warnings if we have large dataset.


How reproducible:
1/1

Steps to Reproduce:
===================
1) Create a x3 volume and start it.
2) FUSE mount it on multiple clients.
3) Run linux kernel untar from two clients .
4) While IO is in-progress, add bricks to the volume and start rebalance without force.

Actual results:
===============
Seeing, "Migrate file failed: <filepath>: failed to get xattr [No data available]" warnings in rebalance logs

Expected results:
================
Should not see the above mentioned warnings

Comment 1 Worker Ant 2018-02-20 14:46:23 UTC
REVIEW: https://review.gluster.org/19603 (cluster/dht: Ignore ENODATA from getxattr for posix acls) posted (#1) for review on master by N Balachandran

Comment 2 Worker Ant 2018-02-22 10:50:36 UTC
COMMIT: https://review.gluster.org/19603 committed in master by "Raghavendra G" <rgowdapp@redhat.com> with a commit message- cluster/dht: Ignore ENODATA from getxattr for posix acls

dht_migrate_file no longer prints an error if getxattr for
posix acls fails with ENODATA/ENOATTR.

Change-Id: Id9ecf6852cb5294c1c154b28d609889ea3420e1c
BUG: 1546954
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:00:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.