Bug 1547068 - Bricks getting assigned to different pids depending on whether brick path is IP or hostname based
Summary: Bricks getting assigned to different pids depending on whether brick path is ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard: brick-multiplexing
Depends On:
Blocks: 1547012
TreeView+ depends on / blocked
 
Reported: 2018-02-20 13:05 UTC by Atin Mukherjee
Modified: 2018-06-20 18:00 UTC (History)
6 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1547012
Environment:
Last Closed: 2018-06-20 18:00:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Atin Mukherjee 2018-02-20 13:07:14 UTC
Description of problem:
=======================
With brick multiplexing enabled, bricks getting assigned to different pids depending on whether brick path is IP or hostname based.


Version-Release number of selected component (if applicable):
mainline

How reproducible:
always

Steps to Reproduce:
===================
1) Enable brick-mux.  
2) Create a volume with server hostnames as below,
gluster v create hostname replica 3 <hostname1:/brickpath> <hostname2:/brickpath> <hostname3:/brickpath> ...
3) Start the volume and make a note of glusterfsd pid
4) Now, create a new volume with server IP as below,
gluster v create IP replica 3 <IP1:/brickpath> <IP2:/brickpath> <IP3:/brickpath> ...
5) Start the volume and make a note of glusterfsd pid.

Actual results:
===============
For the two volumes, two different pids are getting assigned.

Expected results:
=================
As brick-mux is enabled, the two volumes should get the same brick process.

Comment 2 Worker Ant 2018-02-20 13:10:38 UTC
REVIEW: https://review.gluster.org/19601 (glusterd: compare uuid instead of hostname while finding compatible brick) posted (#1) for review on master by Atin Mukherjee

Comment 3 Worker Ant 2018-02-21 22:03:47 UTC
COMMIT: https://review.gluster.org/19601 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- glusterd: compare uuid instead of hostname while finding compatible brick

If the above is not done, bricks created with different IP/hostname will
not be compatible with brick multiplexing.

Change-Id: I508eb59b0632df4b48466cca411c7ec6cc6bd577
BUG: 1547068
Signed-off-by: Atin Mukherjee <amukherj@redhat.com>

Comment 4 Shyamsundar 2018-06-20 18:00:23 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.