Bug 1547226 - heketi-storage-copy-job fails during cns-deploy as it trying to pull a wrong image "heketi/heketi:dev"
Summary: heketi-storage-copy-job fails during cns-deploy as it trying to pull a wrong ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.1
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.9.z
Assignee: Jose A. Rivera
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-20 19:14 UTC by Vítor Corrêa
Modified: 2018-05-17 06:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-05-17 06:42:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:43:24 UTC

Description Vítor Corrêa 2018-02-20 19:14:57 UTC
Description of problem:


Version-Release number of selected component (if applicable):
OCP 3.7 (3.7-23)
openshift-ansible-roles-3.7.23-1.git.0.bc406aa.el7.noarch 
It should be correct by: https://access.redhat.com/errata/RHBA-2017:3438
and https://bugzilla.redhat.com/show_bug.cgi?id=1498595

How reproducible:
Install openshift with the glusterfs, cns-deploy available.

Actual results:

heketi-storage-copy-job cann't be sucsesufelty executed and that caused the next error on the task "openshift_storage_glusterfs : Wait for heketi pod"


Additional info:

A variable "--image {{ glusterfs_heketi_image}}:{{ glusterfs_heketi_version }}" is missing in the file "roles/openshift_storage_glusterfs/tasks/heketi_deploy_part2.yml"

https://github.com/openshift/openshift-ansible/pull/5663/commits/d01c58dabf4a507be5d7225791e78ecfcd46f014

Description of problem:

Version-Release number of the following components:
rpm -q openshift-ansible
rpm -q ansible
ansible --version

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
Please include the entire output from the last TASK line through the end of output if an error is generated

Expected results:

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 2 Jose A. Rivera 2018-03-21 16:14:07 UTC
Looks like this has been already resolved as of 3.7.32-1.

Comment 4 Wenkai Shi 2018-04-18 02:24:58 UTC
Verified with version 3.7.32-1, variable "--image {{ glusterfs_heketi_image}}:{{ glusterfs_heketi_version }}" already in it.

Comment 6 Wenkai Shi 2018-04-20 02:43:31 UTC
Move to verify according to comment 4.

Comment 9 errata-xmlrpc 2018-05-17 06:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.