Bug 1547235 - Cloud-base and Container images for s390x
Summary: Cloud-base and Container images for s390x
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sinny Kumari
QA Contact:
URL:
Whiteboard: ChangeAcceptedF28,SystemWideChange
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-20 19:57 UTC by Jan Kurik
Modified: 2018-05-02 12:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 12:04:07 UTC


Attachments (Terms of Use)

Description Jan Kurik 2018-02-20 19:57:10 UTC
This is a tracking bug for Change: Atomic, Cloud and Container images for s390x
For more details, see: https://fedoraproject.org/wiki/Changes/Atomic_Cloud_and_Docker_images_for_s390x

This change is to bring s390x architecture closer to other Fedora architectures by adding widely used Fedora variants. This includes container images, Atomic Host (iso, qcow2 and raw format) and regular Cloud Images (qcow2 and raw format).

Comment 1 Jan Kurik 2018-02-20 20:05:58 UTC
On 2018-Feb-20, we have reached the Fedora 28 Change Checkpoint: Completion deadline (testable).

At this point, all accepted changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be enabled at Change Completion deadline as well.

Change tracking bug should be set to the MODIFIED state to indicate it achieved completeness.

Incomplete and non testable Changes will be reported to FESCo for 2018-Feb-23 meeting.

Comment 2 Sinny Kumari 2018-02-21 09:16:49 UTC
This change will need a week to get all required changes done.
1. oz - Fedora s390x koji builders has F27 installed. Required f27 oz build is already in bodhi testing (https://bodhi.fedoraproject.org/updates/FEDORA-2018-f0497840ed)
2. Required changes in fedora-pungi is ready (https://pagure.io/pungi-fedora/pull-request/530#) and can be merged quickly after oz update is available in f27.

Comment 3 Sinny Kumari 2018-03-02 14:21:14 UTC
We have changes related to cloud and container merged in pungi-fedora and latest F28 s390x composes are running with these changes. Atomic composes will not be enabled unless we find a solution for slow network transfer from s390 koji builder during ostree repo creation. Link - https://pagure.io/releng/issue/7286#comment-496695

We have successful images from latest F28 nightly compose for testing:
* Cloud ISO - https://kojipkgs.fedoraproject.org/compose/branched/Fedora-28-20180301.n.1/compose/Cloud/s390x/
* container-base image - https://koji.fedoraproject.org/koji/taskinfo?taskID=25403783

Container-minimal and cloud-base images are failing which should be fixed next week after some debugging. cloud-base image is failing most likely due to bz#https://bugzilla.redhat.com/show_bug.cgi?id=1538550 whose fix is known.

Comment 4 Jan Kurik 2018-03-06 08:57:53 UTC
On 2018-Mar-08 we reached the "Change Checkpoint: 100% Code Complete Deadline" milestone for Fedora 28 release. At this point all the Changes not at least in "ON_QA" state should be brought to FESCo for review. Please update the state of this bug to "ON_QA" if it is already 100% completed. Please let me know in case you have any trouble with the implementation and the Change needs any help or review.

Thanks, Jan

Comment 5 Sinny Kumari 2018-03-08 12:05:24 UTC
From latest F28 nightly compose, we are mostly good. Cloud ISO, container-base and container-minimal images are building successfully.
* Cloud ISO - https://kojipkgs.fedoraproject.org/compose/branched/Fedora-28-20180304.n.0/compose/Cloud/s390x/iso/
* container-base image  - https://koji.fedoraproject.org/koji/taskinfo?taskID=25512615
* container-minimal image - https://koji.fedoraproject.org/koji/taskinfo?taskID=25512638

Only item remaining is building successfully cloud-base image. Root cause of this failure has been identified. It is failing because time required by imagefactory to finish building image exceeds specified timeout (which is 7200 seconds in koji). Increasing timeout value should give us successful cloud-base image. Tested locally by increasing imagefactory timeout value (--timeout option) and image builds successfully.

Comment 6 Sinny Kumari 2018-03-16 13:53:40 UTC
For cloud-base image build to succeed in koji, we are waiting on koji PR - https://pagure.io/koji/pull-request/841# to merged . Later, koji package in F27 needs to be built with this patch. Once patched koji update is available, we can configure imagefactory timeout on s390x builder.

Comment 7 Sinny Kumari 2018-03-23 07:07:21 UTC
Required fixes has been done in s390x koji builder to fix cloud-base image build on s390x.

Now, We have some successful cloud-base image built in F28 nightly composes which can be tested - https://kojipkgs.fedoraproject.org/compose/branched/Fedora-28-20180318.n.0/compose/Cloud/s390x/images/

Current status
--------------

* Atomic compose for s390x has been dropped from F28 because of very long time (around 14hrs) taken to create ostree repo on koji builder.
* Change wiki page has been updated to only include cloud-base and container images for s390x in F28 - https://fedoraproject.org/wiki/Changes/Atomic_Cloud_and_Docker_images_for_s390x
* We have successful cloud-base and container images in some of latest nightly compose which can be used for testing.
* We are seeing a common issue across s390x image build which is about not having all images built successfully in a single compose run- https://pagure.io/releng/issue/7405

Comment 8 Zbigniew Jędrzejewski-Szmek 2018-03-23 16:00:56 UTC
> Now, We have some successful cloud-base image built in F28 nightly composes which can be tested

Status moved to ON_QA.


Note You need to log in before you can comment on or make changes to this bug.