Bug 1547374 - [Netvirt][NAT] After migration of NAPT switch there is no connectivity from an instance without FIP to external network
Summary: [Netvirt][NAT] After migration of NAPT switch there is no connectivity from a...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: z5
: 13.0 (Queens)
Assignee: Vishal Thapar
QA Contact: Noam Manos
URL:
Whiteboard: Netvirt
Depends On:
Blocks: 1528948
TreeView+ depends on / blocked
 
Reported: 2018-02-21 07:50 UTC by Itzik Brown
Modified: 2019-03-06 16:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-06 16:14:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Itzik Brown 2018-02-21 07:50:58 UTC
Description of problem:
After running the following scenario couple of times there is no connectivity 
from an instance without Floating IP to an external IP

Version-Release number of selected component (if applicable):
opendaylight-6.2.0-5.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. Create an internal,external network, a router
2. Attach the network to the router
3. Launch an instance on a compute other than the one that holds the NAPT switch
4. Check connectivity from the instance to an external IP
5. Block the port 6653 on the node that holds the NAPT switch
6. Make sure that the switch is migrated
7. Check connectivity from the instance to an external IP
8. Delete all the resources above 
Verify that after couple of times the is no connectivity from the instance to an external IP.


Actual results:


Expected results:


Additional info:

Comment 1 Aswin Suryanarayanan 2018-02-21 07:53:50 UTC
There seems to be stale flows in the setup.  The packets should have hit the latter, but hit the former. Need to check if migration is leading to stale entries.

cookie=0x8000006, duration=28026.028s, table=36, n_packets=438, n_bytes=42924, priority=42,ip,tun_id=0x18716 actions=load:0x30e2c->OXM_OF_METADATA[0..23],resubmit(,44)
cookie=0x8000006, duration=25528.534s, table=36, n_packets=0, n_bytes=0, priority=10,ip,tun_id=0x18716 actions=load:0x30e2c->OXM_OF_METADATA[0..23],ct(table=46,zone=5003,nat)

Comment 2 Mike Kolesnik 2018-03-19 14:32:40 UTC
Does it still happen with the latest ODL version?

Comment 3 Itzik Brown 2018-04-15 10:20:22 UTC
It happens with:
opendaylight-8.0.0-5.el7ost.noarch

When the NAPT switch is moved to a controller it seems to be OK.
When it's moved to a compute node - it isn't.

Comment 9 Franck Baudin 2019-03-06 16:14:38 UTC
As per depreciation notice [1], closing this bug. Please reopen if relevant for RHOSP13, as this is the only version shipping ODL.

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/14/html-single/release_notes/index#deprecated_functionality

Comment 10 Franck Baudin 2019-03-06 16:17:10 UTC
As per depreciation notice [1], closing this bug. Please reopen if relevant for RHOSP13, as this is the only version shipping ODL.

[1] https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/14/html-single/release_notes/index#deprecated_functionality


Note You need to log in before you can comment on or make changes to this bug.