Bug 1547574 - FFU: pacemaker vips are stopped after running upgrade_steps_playbook.yaml
Summary: FFU: pacemaker vips are stopped after running upgrade_steps_playbook.yaml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: beta
: 13.0 (Queens)
Assignee: Emilien Macchi
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-21 14:55 UTC by Marius Cornea
Modified: 2018-06-27 13:46 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180326192239.e59fd2c.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:45:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 553805 None stable/queens: MERGED tripleo-heat-templates: FFU: Upgrades: fix pacemaker checks (I9be9118490a28ee9c24d9c8c89a8daee75e5b817) 2018-03-22 16:57:14 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:46:11 UTC

Description Marius Cornea 2018-02-21 14:55:49 UTC
Description of problem:

Pacemaker vips are stopped after running upgrade_steps_playbook.yaml. This will result in failures during the deploy step caused by services not being able to reach various services, e.g redis. We should probably bring the VIPs up before running the deploy step

[root@controller-0 heat-admin]# pcs status
Cluster name: tripleo_cluster
Stack: corosync
Current DC: controller-0 (version 1.1.16-12.el7_4.7-94ff4df) - partition with quorum
Last updated: Wed Feb 21 01:28:51 2018
Last change: Wed Feb 21 01:16:01 2018 by hacluster via crmd on controller-0

1 node configured
9 resources configured (8 DISABLED)

Online: [ controller-0 ]

Full list of resources:

ip-172.17.3.17 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-172.17.4.16 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-172.17.1.15 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-192.168.24.7 (ocf::heartbeat:IPaddr2): Stopped (disabled)
ip-10.0.0.107 (ocf::heartbeat:IPaddr2): Stopped (disabled)
Clone Set: rabbitmq-clone [rabbitmq]
Stopped (disabled): [ controller-0 ]
Master/Slave Set: redis-master [redis]
Stopped (disabled): [ controller-0 ]
ip-172.17.1.14 (ocf::heartbeat:IPaddr2): Started controller-0
openstack-cinder-volume (systemd:openstack-cinder-volume): Stopped (disabled)

Daemon Status:
corosync: active/enabled
pacemaker: active/enabled
pcsd: active/enabled

Comment 13 errata-xmlrpc 2018-06-27 13:45:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.