Bug 1547595 - Avoid logging at error level for ansible tasks with ignore_errors.
Summary: Avoid logging at error level for ansible tasks with ignore_errors.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.10
Hardware: x86_64
OS: Linux
high
medium vote
Target Milestone: ovirt-4.2.2
: ---
Assignee: Ido Rosenzwig
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: 1455169 1458709
TreeView+ depends on / blocked
 
Reported: 2018-02-21 15:15 UTC by Nikolai Sednev
Modified: 2018-03-29 10:55 UTC (History)
3 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.13-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-03-29 10:55:03 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
engine logs (9.26 MB, application/x-xz)
2018-02-21 15:15 UTC, Nikolai Sednev
no flags Details
alma04 logs (10.42 MB, application/x-xz)
2018-02-21 15:17 UTC, Nikolai Sednev
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 88757 master ABANDONED Ansible: Avoid logging at error level for ansible tasks with ignore_errors 2018-03-12 08:49:40 UTC
oVirt gerrit 88758 ovirt-hosted-engine-setup-2.2 ABANDONED Ansible: Avoid logging at error level for ansible tasks with ignore_errors 2018-03-12 08:49:45 UTC
oVirt gerrit 88788 master MERGED ansible: honor ignore_errors on failures 2018-09-03 09:34:45 UTC
oVirt gerrit 88833 ovirt-hosted-engine-setup-2.2 MERGED ansible: honor ignore_errors on failures 2018-03-12 15:15:43 UTC

Description Nikolai Sednev 2018-02-21 15:15:59 UTC
Created attachment 1398808 [details]
engine logs

Description of problem:
Avoid logging at error level for ansible tasks with ignore_errors.
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Make the engine aware that the external VM is stopped]
[ ERROR ] Error: Fault reason is "Operation Failed". Fault detail is "[Desktop does not exist]". HTTP response code is 400.
[ ERROR ] fatal: [localhost]: FAILED! => {"changed": false, "msg": "Fault reason is \"Operation Failed\". Fault detail is \"[Desktop does not exist]\". HTTP response code is 400."}
[ INFO  ] TASK [Wait for the local bootstrap VM to be down at engine eyes]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Remove boostrap external VM from the engine]
[ INFO  ] changed: [localhost]
[ INFO  ] Stage: Clean up
[ INFO  ] Cleaning temporary resources
[ INFO  ] TASK [Gathering Facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [include_tasks]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Remove local vm dir]
[ INFO  ] changed: [localhost]
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20180221155736.conf'
[ INFO  ] Generating answer file '/etc/ovirt-hosted-engine/answers.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ INFO  ] Hosted Engine successfully deployed

alma04 ~]# hosted-engine --vm-status


--== Host 1 status ==--

conf_on_shared_storage             : True
Status up-to-date                  : True
Hostname                           : alma04
Host ID                            : 1
Engine status                      : {"health": "good", "vm": "up", "detail": "Up"}
Score                              : 3400
stopped                            : False
Local maintenance                  : False
crc32                              : 96138d6e
local_conf_timestamp               : 5529
Host timestamp                     : 5528
Extra metadata (valid at timestamp):
        metadata_parse_version=1
        metadata_feature_version=1
        timestamp=5528 (Wed Feb 21 16:39:00 2018)
        host-id=1
        score=3400
        vm_conf_refresh_time=5529 (Wed Feb 21 16:39:01 2018)
        conf_on_shared_storage=True
        maintenance=False
        state=EngineUp
        stopped=False


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-ha-2.2.5-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.10-1.el7ev.noarch
rhvm-appliance-4.2-20180202.0.el7.noarch
Linux 3.10.0-851.el7.x86_64 #1 SMP Mon Feb 12 07:53:52 EST 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 Beta (Maipo)

How reproducible:
100%

Steps to Reproduce:
1.Deploy SHE ansible over NFS on RHEL7.5 host.

Actual results:
Although deployment succeeds, there are errors in CLI during deployment and after trying to log in to UI, customer receives these in browser:
"This page isn’t working
nsednev-he-2.qa.lab.tlv.redhat.com redirected you too many times.
Try clearing your cookies."

Expected results:
No errors should appear. Browser should let the customer log in normally, without closing all browser tabs and and opening new browser session.

Additional info:
Sosreport from engine and host.

Comment 1 Nikolai Sednev 2018-02-21 15:17:08 UTC
Created attachment 1398809 [details]
alma04 logs

Comment 2 Nikolai Sednev 2018-03-18 15:09:36 UTC
Works for me on these components:
ovirt-hosted-engine-ha-2.2.7-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.13-1.el7ev.noarch
rhvm-appliance-4.2-20180202.0.el7.noarch
Linux 3.10.0-861.el7.x86_64 #1 SMP Wed Mar 14 10:21:01 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)
Deployed over NFS and did not seen any originally reported errors.

[ INFO  ] TASK [Make the engine aware that the external VM is stopped]
[ INFO  ] TASK [Wait for the local bootstrap VM to be down at engine eyes]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Remove boostrap external VM from the engine]
[ INFO  ] changed: [localhost]
[ INFO  ] TASK [Include custom tasks for after setup customization]
[ INFO  ] Stage: Clean up
[ INFO  ] Cleaning temporary resources
[ INFO  ] TASK [Gathering Facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [include_tasks]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Remove local vm dir]
[ INFO  ] changed: [localhost]
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20180318170504.conf'
[ INFO  ] Generating answer file '/etc/ovirt-hosted-engine/answers.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ INFO  ] Hosted Engine successfully deployed

Comment 3 Sandro Bonazzola 2018-03-29 10:55:03 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.