Bug 15476 - g++: internal compiler error in scan_region (compiling hylafax)
g++: internal compiler error in scan_region (compiling hylafax)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-05 10:32 EDT by giulioo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-21 06:45:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Files needed to reproduce the compiler error (cd test-dir/faxmail;make) (64.31 KB, application/octet-stream)
2000-08-05 10:36 EDT, giulioo
no flags Details

  None (edit)
Description giulioo 2000-08-05 10:32:09 EDT
There is an utility in hylafax that cannot be built on pinstripe, while it 
builds ok on rh61.

I assume it's a compiler bug since the compiler seems to say so; I don't 
understand anything about compilers.

/usr/bin/g++        -D__ANSI_CPP__ -I. -I.. -I.././regex -I.././faxmail -
I.././u
til -I/usr/include -g -O  -c MsgFmt.c++
MsgFmt.c++: In method `fxStr MsgFmt::mapHeader (const fxStr &)':
MsgFmt.c++:68: Internal compiler error in scan_region, at except.c:2808
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.
make[1]: *** [MsgFmt.o] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/hylafax-cvs-
20000604/faxmail'
make: *** [default] Error 2

I'm using the hylafax source that comes with the latest srpm from 
ftp.hylafax.org: hylafax-4.1beta2-5rh6.src.rpm

For your convenience I'm  attaching a tar.gz with just the files needed to 
reproduce the error.

tar zxvf test-dir.tar.gz
cd test-dir/faxmail
make
Comment 1 giulioo 2000-08-05 10:36:26 EDT
Created attachment 2096 [details]
Files needed to reproduce the compiler error (cd test-dir/faxmail;make)
Comment 2 giulioo 2000-08-15 12:25:49 EDT
I see now that I can compile it ok if I take "-O" out.
However, since rh61 can compile it with "-O", I still thinks it may be 
considered a bug.
Comment 3 Jakub Jelinek 2000-08-21 06:44:39 EDT
Yes, it is considered a bug.
BTW: -O2 and above works as well, it is just -O which ICEs.
I have distilled a small testcase from it which I'm submitting to gcc-patches,
and will try to debug it.
Comment 4 Jakub Jelinek 2000-08-25 09:16:48 EDT
Fixed in gcc-c++-2.96-54

Note You need to log in before you can comment on or make changes to this bug.