Bug 1547607 - satellite-installer --upgrade fails on db:migrate
Summary: satellite-installer --upgrade fails on db:migrate
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: SCAP Plugin
Version: 6.3.0
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Ondřej Pražák
QA Contact: Sanket Jagtap
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-21 15:36 UTC by Andreas Bleischwitz
Modified: 2019-08-12 16:07 UTC (History)
14 users (show)

Fixed In Version: tfm-rubygem-foreman_openscap-0.7.13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-13 13:32:28 UTC


Attachments (Terms of Use)
full satellite installer log (148.54 KB, text/plain)
2018-02-21 17:04 UTC, Andreas Bleischwitz
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1126 None None None 2018-04-13 13:33:08 UTC
Foreman Issue Tracker 22668 None None None 2018-02-23 09:08:58 UTC

Description Andreas Bleischwitz 2018-02-21 15:36:45 UTC
Description of problem:
During the upgrade of Satellite the migration of the database fails and the upgrade is stopped. Any re-start of the upgrade fails with the same error

Version-Release number of selected component (if applicable):

# rpm -q satellite
satellite-6.3.0-23.0.el7sat.noarch


How reproducible:

Update from satellite-6.2.14-4.0.el7sat.noarch.


Actual results:
[ INFO 2018-02-21 16:16:12 main] Upgrade Step: migrate_foreman...
[DEBUG 2018-02-21 16:16:39 main] rake aborted!
[DEBUG 2018-02-21 16:16:39 main] StandardError: An error has occurred, this and all later migrations canceled:
[DEBUG 2018-02-21 16:16:39 main] 
[DEBUG 2018-02-21 16:16:39 main] Failed to destroy the record/opt/rh/rh-ror42/root/usr/share/gems/gems/activerecord-4.2.6/lib/active_record/persistence.rb:185:in `destroy!'
[DEBUG 2018-02-21 16:16:39 main] /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.7.11/db/migrate/20171011134112_remove_arf_reports_without_policy.rb:5:in `map'
[DEBUG 2018-02-21 16:16:39 main] /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.7.11/db/migrate/20171011134112_remove_arf_reports_without_policy.rb:5:in `block in up'
[DEBUG 2018-02-21 16:16:39 main] /opt/rh/rh-ror42/root/usr/share/gems/gems/activerecord-4.2.6/lib/active_record/relation/batches.rb:124:in `find_in_batches'
[DEBUG 2018-02-21 16:16:39 main] /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.7.11/db/migrate/20171011134112_remove_arf_reports_without_policy.rb:4:in `up'
[DEBUG 2018-02-21 16:16:39 main] /opt/rh/rh-ror42/root/usr/share/gems/gems/activerecord-4.2.6/lib/active_record/migration.rb:611:in `exec_migration'


Expected results:
Upgrade finishes without error.

Additional info:
I fixed this issue by removing the "!" from /opt/theforeman/tfm/root/usr/share/gems/gems/foreman_openscap-0.7.11/db/migrate/20171011134112_remove_arf_reports_without_policy.rb:

--- 20171011134112_remove_arf_reports_without_policy.rb-old	2018-02-21 16:19:53.259631092 +0100
+++ 20171011134112_remove_arf_reports_without_policy.rb	2018-02-21 16:22:27.050573034 +0100
@@ -2,7 +2,7 @@
   def up
     ids_to_keep = ForemanOpenscap::ArfReport.unscoped.all.joins(:policy_arf_report).pluck(:id)
     ForemanOpenscap::ArfReport.unscoped.where.not(:id => ids_to_keep).find_in_batches do |batch|
-      batch.map(&:destroy!)
+      batch.map(&:destroy)
     end
   end
 end

Comment 1 Evgeni Golov 2018-02-21 15:44:41 UTC
Andreas, do you have the *full* log of the upgrade available?

ActiveRecord::Persistence.destroy! raises an error if the destroy did not work out, ActiveRecord::Persistence.destroy does not, so you basically have hidden the problem ;)

Comment 2 Andreas Bleischwitz 2018-02-21 17:04:50 UTC
Created attachment 1398912 [details]
full satellite installer log

Comment 5 Ondřej Pražák 2018-02-23 09:08:55 UTC
Created redmine issue http://projects.theforeman.org/issues/22668 from this bug

Comment 9 pm-sat@redhat.com 2018-02-26 11:03:34 UTC
Upstream bug assigned to oprazak@redhat.com

Comment 10 pm-sat@redhat.com 2018-02-26 11:03:39 UTC
Upstream bug assigned to oprazak@redhat.com

Comment 16 Sanket Jagtap 2018-04-02 05:30:29 UTC
Build: Satellite 6.3.1 snap1 


Reproducer steps:
1) Have a scap policy 
2) Create a report from the policy 
3) delete the policy 
4) Upgrade your 6.2.14 to 6.3


The upgrade from 6.2.14 to 6.3 was successfully with the orphan arf report in it 
The upgrade successfully remove the orphan arf reports

[qe-sat6-] out: 
[qe-sat6-] out: == 20171011134112 RemoveArfReportsWithoutPolicy: migrating ====================
[qe-sat6-] out: == 20171011134112 RemoveArfReportsWithoutPolicy: migrated (0.0839s) ===========

Comment 18 errata-xmlrpc 2018-04-13 13:32:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1126


Note You need to log in before you can comment on or make changes to this bug.