Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1547683

Summary: Webadmin - Events repeating events 31 times per occurrence
Product: [oVirt] ovirt-engine Reporter: mlehrer
Component: BLL.InfraAssignee: Ravi Nori <rnori>
Status: CLOSED CURRENTRELEASE QA Contact: Lucie Leistnerova <lleistne>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.2.2CC: bugs, lveyde, mlehrer, mperina, rnori
Target Milestone: ovirt-4.2.2Flags: rule-engine: ovirt-4.2+
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ovirt-engine-4.2.2.4 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-29 11:04:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
Duplicated events tab of same time in Events Tab none

Description mlehrer 2018-02-21 17:17:29 UTC
Created attachment 1398913 [details]
Duplicated events tab of same time in Events Tab

Description of problem:

Nested host became unreachable.
Events tab in web admin reports the event 31 times per occurrence.


Version-Release number of selected component (if applicable):
4.2.2-0.1.el7


How reproducible:
Reproduces.

Steps to Reproduce:
1. Create nested host
2. Prevent host from communicating with engine
3. Check events tab

Actual results:

Event is repeated 31 times per message occurrence.

Expected results:
1 message per event per time it occurred.

Additional info:
This environment has 284 hosts and 1,418 vms.
4 DCs and 4 SD's.

Image attached.
engine sos logs available: 
https://drive.google.com/open?id=1oJRP9TME3H3X5DaQW1aAmnk1IaSRJh9X

Comment 1 Yaniv Kaul 2018-02-22 07:53:35 UTC
1. It has nothing to do with webadmin. Please set to the right component and team.
2. What is the specific error?

Comment 2 Eli Mesika 2018-02-26 20:50:08 UTC
From the attached gif it seems that the event is VDS_BROKER_COMMAND_FAILURE (event id : 10802)

The audit log has a event flooding mechanism that allows us to suppress identical events in a given time-interval 

However, the VDS_BROKER_COMMAND_FAILURE is not suppressed.

When looking for this event in engine.log under the sos report, there are many events that looks like :

2018-02-21 03:38:47,200Z ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (EE-ManagedThreadFactory-engineScheduled-Thread-35) [] EVENT_ID: VDS_BROKER_COMMAND_FAILURE(10,802), VDSM stage5 command GetCapabilitiesAsyncVDS failed: Vds timeout occured

So, actually the GetCapabilitiesAsyncVDS is failing each time with a different thread, so , events are not identical  but occur one after another in multiple threads. 

If you think the VDS_BROKER_COMMAND_FAILURE should be suppressed, please specify why and what do you think is the desired time interval for it ....

Comment 3 mlehrer 2018-02-26 23:16:20 UTC
(In reply to Eli Mesika from comment #2)
> From the attached gif it seems that the event is VDS_BROKER_COMMAND_FAILURE
> (event id : 10802)
> 
> The audit log has a event flooding mechanism that allows us to suppress
> identical events in a given time-interval 
> 
> However, the VDS_BROKER_COMMAND_FAILURE is not suppressed.
> 
> When looking for this event in engine.log under the sos report, there are
> many events that looks like :
> 
> 2018-02-21 03:38:47,200Z ERROR
> [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector]
> (EE-ManagedThreadFactory-engineScheduled-Thread-35) [] EVENT_ID:
> VDS_BROKER_COMMAND_FAILURE(10,802), VDSM stage5 command
> GetCapabilitiesAsyncVDS failed: Vds timeout occured
> 
> So, actually the GetCapabilitiesAsyncVDS is failing each time with a
> different thread, so , events are not identical  but occur one after another
> in multiple threads. 
> 

I understand it might use different threads and thus the failures that were  thrown are repeated, but from the user experience point of view the issues  appear as the same information repeated for several lines because the entity being reported is the same.  

I would expect any notification which is related to the same entity and same event id/message reported within x amount of seconds to show once with a message indicating the number of times its failed or to see a 'rolled up' parent event.

The way it works currently might cause users to miss other events and in larger systems where hosts might flap the events pane looks very busy and becomes harder to follow/understand.  Consider a scenario where a production instance starts having issues and the events pane is used in real time to trouble shoot, if several hosts are unreachable the log will be hard to follow from the UI.

> If you think the VDS_BROKER_COMMAND_FAILURE should be suppressed, please
> specify why and what do you think is the desired time interval for it ....

You mentioned that currently there exists a flood mechanism for similar events within a given time period.  Is the time period the same for all events?

If the time period varies, is it possible to show this event per affected asset once per 30s? Please discuss with PM.

Comment 4 Eli Mesika 2018-02-27 06:07:02 UTC
(In reply to mlehrer from comment #3)

> I would expect any notification which is related to the same entity and same
> event id/message reported within x amount of seconds to show once with a
> message indicating the number of times its failed or to see a 'rolled up'
> parent event.
> 

This sounds as a RFE, you can fill one and we can discuss it...

> You mentioned that currently there exists a flood mechanism for similar
> events within a given time period.  Is the time period the same for all
> events?

No, it varies from seconds to hours ...
> 
> If the time period varies, is it possible to show this event per affected
> asset once per 30s? Please discuss with PM.

Yes, If PM will approve that

Comment 5 Martin Perina 2018-02-28 10:38:08 UTC
Ravi, couldn't this be related to non-blocking thread changes?

Comment 6 Martin Perina 2018-03-01 14:55:16 UTC
As discussed offline, the message is not repeated 31 times, but it's reported by 31 hosts at around the same time. We will add a host identification to the message

Comment 7 Martin Perina 2018-03-06 08:10:53 UTC
Not included in ovirt-engine-4.2.2.2 build, moving back to MODIFIED

Comment 8 Lucie Leistnerova 2018-03-20 11:45:11 UTC
When host is not accessible, in engine log error appears every 3-6s, but in events errors appear only few per some minutes.

verified in ovirt-engine-4.2.2.4-0.1.el7.noarch

Comment 9 Sandro Bonazzola 2018-03-29 11:04:33 UTC
This bugzilla is included in oVirt 4.2.2 release, published on March 28th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.2 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.