Bug 1547691 - Mouse not working in rawhide
Mouse not working in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
28
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Florian Müllner
Fedora Extras Quality Assurance
:
: 1550046 (view as bug list)
Depends On:
Blocks: 1551990 F28BetaBlocker
  Show dependency treegraph
 
Reported: 2018-02-21 13:08 EST by Milan Crha
Modified: 2018-03-06 05:03 EST (History)
27 users (show)

See Also:
Fixed In Version: mutter-3.27.91-2.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-05 10:52:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 105208 None None None 2018-02-22 07:34 EST

  None (edit)
Description Milan Crha 2018-02-21 13:08:29 EST
I've a virtual machine with rawhide, which I updated to the latest few minutes ago. It brought in gdm-3.27.4-4.fc28.x86_64 and thousands of other updates. Since then, clicking in gdm with mouse does literally nothing. Once again, this is a virtual machine, not a real machine. When I log in (using keyboard only), the mouse does what it should do, thus clicking on buttons, Activities, whatever does the same as before the update. Yes, I did restart whole virtual machine after he update.
Comment 1 Yanko Kaneti 2018-02-21 13:51:42 EST
I've been trying unsuccessfully to pinpoint the issue in the last couple days.
And I am on real hardware.  The mouse pointer moves ok, just does not seem to be registered in the compositor windows, and the buttons don't do anything.

Today a breakthrough :) Its the mesa upgrade that broke it. 

mesa-17.3.5-1.fc27       - works
mesa-18.0.0-0.1.rc4.fc28 - doesn't work
Comment 2 Yanko Kaneti 2018-02-21 13:59:00 EST
With everytihng else the same.

And FWIF - the mouse works fine in weston, so I suspect some mutter/shell oddity
Comment 3 Couret Charles-Antoine 2018-02-21 13:59:47 EST
The same bug. I don't have this issue from TTY with kernel layer.
GNOME Shell is concerned too (not only GDM).
Comment 4 Yanko Kaneti 2018-02-21 14:52:36 EST
I've isolated it a bit further to the mesa-dri-drivers
i.e everything 18.0.0-0.1.rc4.fc28 but with mesa-dri-drivers-17.3.5-1.fc27.x86_64  works fine
Comment 5 Yanko Kaneti 2018-02-21 18:42:22 EST
Rebuilt 18.0.0-0.1.rc4 on F27 current to isolate the toolchain/llvm, but it was still broken the same way, so probably the problem is isolated to mesa.
Comment 6 Jens Petersen 2018-02-22 01:08:45 EST
Should this move to Mesa component then?
Comment 7 Jens Petersen 2018-02-22 01:14:00 EST
I can use the mouse fine in Xorg Gnome though -
so Wayland GNOME shell does seem to be an issue.
Comment 8 Jens Petersen 2018-02-22 01:45:14 EST
Also I am not sure if the host display system (Wayland vs Xorg) matters?
Comment 9 Igor Gnatenko 2018-02-22 02:13:04 EST
Mind reporting this to upstream bugs.freedesktop.org?
Comment 10 Jens Petersen 2018-02-22 02:52:40 EST
Against which product? :)
Comment 11 Yanko Kaneti 2018-02-22 07:33:40 EST
Bisected to mesa commit  

e5ff036c67 st/dri: Add support for BGR[A/X]1010102 formats

Filed a bug upstream https://bugs.freedesktop.org/show_bug.cgi?id=105208

Straight up reverting that commit on top of 18.0  rc4 and applying the reveret to the mesa packages fixes it for me..
Comment 12 Daniel Stone 2018-02-22 08:03:10 EST
This is ultimately a Mutter bug: https://gitlab.gnome.org/GNOME/mutter/issues/2
Comment 13 Yanko Kaneti 2018-02-26 12:44:36 EST
There are pending mutter patches to fix the issue without disabling 10-bits in mesa completely. Moving to mutter
Comment 14 Jens Petersen 2018-02-28 07:19:11 EST
*** Bug 1550046 has been marked as a duplicate of this bug. ***
Comment 15 Adam Williamson 2018-02-28 12:23:08 EST
I'm backporting the current state of MR#36 to Rawhide and F28 so we have a fix for this (whenever we can get a damn compose built).
Comment 16 Jens Petersen 2018-03-01 00:42:08 EST
Thanks, however neither mutter-3.27.91-1.fc28 nor mutter-3.27.91-2.fc28
start GNOME Shell for me.  Downgrading to mutter-3.27.1-4.fc28
allows both GNOME and Xorg GNOME to start.
Comment 17 Jens Petersen 2018-03-01 00:43:35 EST
This also agrees with Fedora-Workstation-Live-x86_64-28-20180221.n.0.iso
booting to a black screen (desktop session).
Comment 18 Parag Nemade 2018-03-01 01:47:11 EST
I confirm after updating to latest mutter-3.27.91-1.fc28 build, mouse still not working in f28 installed in virtual machine.
Comment 19 Parag Nemade 2018-03-01 09:36:31 EST
Looks like mouse start working after installing build mutter-3.27.91-2.fc28
Comment 20 Adam Williamson 2018-03-02 12:48:08 EST
Jens, sounds like you possibly have a different bug here, if it works for Parag?
Comment 21 Jens Petersen 2018-03-04 22:04:19 EST
Yeah I dunno: anyway Fedora-Workstation-Live-x86_64-28-20180302.n.0.iso
Live instance works fine for me, so this can be closed now I think.
Comment 22 Adam Williamson 2018-03-05 10:52:38 EST
Roger, closing. Thanks!
Comment 23 Milan Crha 2018-03-05 12:13:45 EST
Okay, I can confirm the mouse clicks on the elements of gdm do work, but I also noticed that any mouse move, either above an element or even on the grey background where is exactly nothing to click on, generates high CPU usage. The CPU usage goes back down as soon as I stop moving the mouse. The 'top' shows gnome-shell killing the CPU, when I'm logged in GNOME.

This problem is more visible in Wayland session (and gdm), but I see it in X.org too, it's only not that significant.

I have installed up-to-date rawhide, with mutter-3.27.91-2.fc29.x86_64 and gnome-shell-3.27.91-2.fc29.x86_64 and also 3.27.91 gnome-shell-extensions.

I downgraded these to older versions, where mouse doesn't work in Wayland, but it also does that high CPU usage, thus it's nothing new, it had been there even before. It made me think of Fedora 27 and I see a high CPU usage in gdm when moving mouse here and there too.

I guess you want a new bug for this high CPU usage (thus higher power consumption), do you not? Or, if it's known in F27, then probably no big deal, because it's not a regression. I'd mention that both of these machines are virtual, not real, and they are updated as of today. I tried also with F26 virtual machine and the gdm doesn't consume that much CPU as F27 and rawhide, when moving the mouse, it's quite insignificant CPU usage in F26 with compare of the two newer Fedoras.
Comment 24 Adam Williamson 2018-03-05 16:48:41 EST
Yes, I'd say file that as a separate bug. If it broke between 26 and 27 it certainly seems worth at least considering as a bug.
Comment 25 Milan Crha 2018-03-06 05:03:44 EST
Okay, I filled bug #1551990. I'm unsure I chose the right component, neither I know whether I should CC there any person from the power consumption team (supposing there's anyone at all).

Note You need to log in before you can comment on or make changes to this bug.