Bug 1547841 - Typo error in __dht_check_free_space function log message
Summary: Typo error in __dht_check_free_space function log message
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.12
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1547128 1547842
Blocks: 1546960
TreeView+ depends on / blocked
 
Reported: 2018-02-22 04:53 UTC by Nithya Balachandran
Modified: 2018-04-06 11:06 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.12.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1547128
Environment:
Last Closed: 2018-04-06 11:06:55 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Nithya Balachandran 2018-02-22 04:53:19 UTC
+++ This bug was initially created as a clone of Bug #1547128 +++

+++ This bug was initially created as a clone of Bug #1546960 +++

Description of problem:
======================
There is a type error in __dht_check_free_space function log message.

[2018-02-20 05:34:48.556248] W [MSGID: 109023] [dht-rebalance.c:962:__dht_check_free_space] 0-distrepx3-dht: data movement of file {blocks:7 name:(/1/linux-4.6.4/Documentation/device-mapper/era.txt) } would result in dst node (distrepx3-replicate-1:41274488) having lower disk space then the source node (distrepx3-replicate-2:41445560).Skipping file.

Message "then the source node" has to be corrected to "than the source node"

And we can remove the extra space before closing flower brace {blocks:7 name:(/1/linux-4.6.4/Documentation/device-mapper/era.txt) }

Version-Release number of selected component (if applicable):
3.12.2-4.el7rhgs.x86_64

Steps to Reproduce:
====================
1) create a gluster volume and start it.
2) FUSE mount on a volume and start IO.
3) Add bricks to the volume and, make sure that there is some space discrepancy 
4) start the rebalance without force option
gluster volume rebalance <vol> start 
5) Check the status of rebalance and make sure that some skipped files are there

Actual results:
================
Log message has typo at then
"lower disk space then the source node" 

Expected results:
=================
Fix typo.

--- Additional comment from Worker Ant on 2018-02-20 10:10:56 EST ---

REVIEW: https://review.gluster.org/19604 (cluster/dht: Fixed a typo) posted (#1) for review on master by N Balachandran

--- Additional comment from Worker Ant on 2018-02-21 17:06:56 EST ---

COMMIT: https://review.gluster.org/19604 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- cluster/dht: Fixed a typo

Replaced "then" with "than"

Change-Id: I73090e8c1a639befd7c5458e8d63bd173248bc7d
BUG: 1547128
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 1 Worker Ant 2018-02-22 04:59:41 UTC
REVIEW: https://review.gluster.org/19613 (cluster/dht: Fixed a typo) posted (#1) for review on release-3.12 by N Balachandran

Comment 2 Worker Ant 2018-03-05 04:38:24 UTC
COMMIT: https://review.gluster.org/19613 committed in release-3.12 by "jiffin tony Thottan" <jthottan@redhat.com> with a commit message- cluster/dht: Fixed a typo

Replaced "then" with "than"

> Change-Id: I73090e8c1a639befd7c5458e8d63bd173248bc7d
> BUG: 1547128
> Signed-off-by: N Balachandran <nbalacha@redhat.com>

Change-Id: I73090e8c1a639befd7c5458e8d63bd173248bc7d
BUG: 1547841
Signed-off-by: N Balachandran <nbalacha@redhat.com>

Comment 3 Jiffin 2018-04-06 11:06:55 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.7, please open a new bug report.

glusterfs-3.12.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/maintainers/2018-March/004303.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.