Bug 1548085 - OSP13: Discover tag command not working due to no label version-release. Available labels: version 2018-02-22.1
Summary: OSP13: Discover tag command not working due to no label version-release. Ava...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Steve Baker
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On: 1543707
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-22 16:36 UTC by Omri Hochman
Modified: 2018-06-27 13:46 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:45:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:46:11 UTC

Description Omri Hochman 2018-02-22 16:36:58 UTC
OSP13:  Discover tag command not working due to no label version-release. Available labels: version 2018-02-22.1

environment:
------------
openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost.noarch
docker-client-1.13.1-55.rhel75.git774336d.el7.x86_64
python-docker-2.4.2-1.3.el7.noarch
docker-distribution-2.6.2-1.git48294d9.el7.x86_64
docker-common-1.13.1-55.rhel75.git774336d.el7.x86_64
python-docker-pycreds-1.10.6-3.el7.noarch
docker-1.13.1-55.rhel75.git774336d.el7.x86_64
docker-rhel-push-plugin-1.13.1-55.rhel75.git774336d.el7.x86_64

Steps to reproduce: 
--------------------

Attempt to use openstack overcloud container image tag discover with latest osp13 puddle version : 

[stack@undercloud75 bm-upgrade-tests]$ puddle-version http://download-node-02.eng.bos.redhat.com/rcm-guest/puddles/OpenStack/13.0-RHEL-7/latest
2018-02-22.1

[stack@undercloud75 bm-upgrade-tests]$ openstack overcloud container image tag discover --image docker-registry.engineering.redhat.com/rhosp13/openstack-base:2018-02-22.1 --tag-from-label version-release

Results:
--------
Image docker-registry.engineering.redhat.com/rhosp13/openstack-base:2018-02-22.1 has no label version-release. Available labels:

Comment 2 Steve Baker 2018-02-22 19:45:54 UTC
This is a regression in skopeo-0.1.28 that I've already raised a bug against skopeo

Comment 3 Omri Hochman 2018-02-22 19:49:59 UTC
w/a as internal redhat employee was to set manually tag=2018-02-22.1, 
customer won't have this information about the latest tag, therefore we're raising blocker for this issue.

Comment 5 Steve Baker 2018-03-05 21:24:24 UTC
I've set a NEEDINFO for mitr@redhat.com in the skopeo bug #1543707

The fix exists in the unmerged branch https://github.com/mtrmac/skopeo/commits/305-cleanup

Comment 10 Steve Baker 2018-03-19 22:59:15 UTC
Upstream master skopeo now returns labels for inspect calls

Comment 12 Emilien Macchi 2018-03-22 16:16:44 UTC
skopeo-0.1.29-1 has been pushed to rhel-7.5-extras, so it's ready to be verified.

Comment 15 Emilien Macchi 2018-03-22 16:24:48 UTC
skopeo-0.1.29-1 has been pushed to rhel-7.5-extras, see https://bugzilla.redhat.com/show_bug.cgi?id=1543707

Comment 17 Steve Baker 2018-03-22 20:24:16 UTC
Also, skopeo-0.1.29-1.dev.gitb08350d is in the rhelosp-rhel-7.5-extras repo which is set up by current puddles.

Comment 20 Omri Hochman 2018-03-26 14:12:46 UTC
That's what I'm getting with latest puddle "has no label version-release".

openstack overcloud container image tag discover --image docker-registry.engineering.redhat.com/rhosp13/openstack-base:2018-03-20.2 --tag-from-label version-release
Image docker-registry.engineering.redhat.com/rhosp13/openstack-base:2018-03-20.2 has no label version-release. Available labels: io.k8s.description, tripleo-common_version, vcs-ref, authoritative-source-url, io.k8s.display-name, kolla_version, version, Kolla-SHA, com.redhat.component, distribution-scope, vendor, description, vcs-type, com.redhat.build-host, build-date, name, url, batch, summary, architecture, release, io.openshift.tags

Comment 21 Omri Hochman 2018-03-26 14:13:51 UTC
please let me know if there anything I'm doing wrong on the command,  meanwhile switching to failed_QA /Assigned.

Comment 22 Alexander Chuzhoy 2018-03-26 14:33:48 UTC
The above is spotted with:
skopeo-0.1.29-1.dev.gitb08350d.el7.x86_64

Comment 23 Steve Baker 2018-03-26 20:36:47 UTC
This looks like there really is no label version-release on the image, but I don't think we should be fixing the image building to add it back. 

Discover now supports using multiple labels, so can you please retest with the following instead:

  --tag-from-label {version}-{release}

Any internal docs which refer to version-release need to be updated to {version}-{release}.

Here is my docs change to stop using the separate discover command, and switching to {version}-{release}

https://gitlab.cee.redhat.com/sbaker/docs-Red_Hat_Enterprise_Linux_OpenStack_Platform/commit/9ae8d5481fde7f4e21d9891786be3dc61568a60b

Comment 24 Alexander Chuzhoy 2018-03-26 21:15:27 UTC
Verified:

Version: skopeo-0.1.29-1.dev.gitb08350d.el7.x86_64


The proper argument is: --tag-from-label {version}-{release}

Need to use the brackets!

Filed a doc bug: 
https://bugzilla.redhat.com/show_bug.cgi?id=1560734

Comment 25 Omri Hochman 2018-03-27 08:13:06 UTC
Works thanks 

[stack@undercloud75 ~]$ openstack overcloud container image tag discover --image docker-registry.engineering.redhat.com/rhosp13/openstack-base:2018-03-20.2  --tag-from-label {version}-{release}
13.0-20

Comment 28 errata-xmlrpc 2018-06-27 13:45:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.