Bug 1548174 - "Actual Timezone in Guest Differs from Configuration Error" - PST / GMT -8 - Windows VM
Summary: "Actual Timezone in Guest Differs from Configuration Error" - PST / GMT -8 - ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.9
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ovirt-4.2.2
: ---
Assignee: Michal Skrivanek
QA Contact: Vitalii Yerys
URL:
Whiteboard:
Depends On:
Blocks: 1552811
TreeView+ depends on / blocked
 
Reported: 2018-02-22 22:30 UTC by amashah
Modified: 2021-06-10 14:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1552811 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:48:28 UTC
oVirt Team: Virt
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3363111 0 None None None 2018-03-05 20:18:28 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:49:44 UTC
oVirt gerrit 88402 0 master MERGED core: remove duplicate PST timezone mapping 2021-02-02 15:13:19 UTC
oVirt gerrit 88420 0 ovirt-engine-4.2 MERGED core: remove duplicate PST timezone mapping 2021-02-02 15:13:19 UTC
oVirt gerrit 88425 0 ovirt-engine-4.1 MERGED core: remove duplicate PST timezone mapping 2021-02-02 15:13:19 UTC

Description amashah 2018-02-22 22:30:12 UTC
Description of problem:

Windows 10 Pro and Windows Server 2012 R2 were tested with the latest RHEV Tools installed, and in RHV-M have the ! indicating that Timezone in guest differs from configuration error. This is only noticed with PST (GMT -8) as the Timezone.

Version-Release number of selected component (if applicable):

RHV 4.1.9, RHEV Tools 4.1-7, Windows 10 Pro, Windows Server 2012 R2

How reproducible: 100%

Steps to Reproduce:
1. Install Windows VM, set hardware offset to GMT -8 
2. Set Windows VM to PST -8
3. Observe ! in RHV-M

Actual results:
! in RHV-M to the left of the VM indicating "Actual Timezone in Guest Differs from Configuration Error".

Expected results:
There should not be any reported time differences.


Additional info: 

engine=> select utc_diff,guest_timezone_offset from vm_dynamic where vm_guid = (select vm_guid from vm_static where vm_name ='win10-test');

 utc_diff | guest_timezone_offset 
----------+-----------------------
   -28800 |                  -480

This appears to be correct. Also there are several time zones for -8 in Windows 10, all of them report this error.

Comment 4 RHV bug bot 2018-03-07 16:25:03 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found clone flags: ['rhevm-4.1.z', 'rhevm-4.2-ga'], ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found clone flags: ['rhevm-4.1.z', 'rhevm-4.2-ga'], ]

For more info please contact: rhv-devops@redhat.com

Comment 6 Vitalii Yerys 2018-03-16 16:40:11 UTC
Verified with:
Software Version:4.2.2.4-0.1.el7

Comment 10 errata-xmlrpc 2018-05-15 17:48:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 11 Franta Kust 2019-05-16 13:04:16 UTC
BZ<2>Jira Resync

Comment 12 Daniel Gur 2019-08-28 13:12:10 UTC
sync2jira

Comment 13 Daniel Gur 2019-08-28 13:16:23 UTC
sync2jira


Note You need to log in before you can comment on or make changes to this bug.