Bug 15484 - GNOME Tasklist keeps closing
Summary: GNOME Tasklist keeps closing
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-applets   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-05 16:02 UTC by bkosse
Modified: 2007-04-18 16:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-14 18:49:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to work around the problem, works for me (only?) (479 bytes, patch)
2001-12-06 22:56 UTC, Stas Sergeev
no flags Details | Diff

Description bkosse 2000-08-05 16:02:38 UTC
<P>I can't see any remnants of a core-file or similar, but the tasklist
keeps closing on me. It may be related to this error, though:
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
  serial 107701 error_code 9 request_code 63 minor_code 0

Comment 1 bkosse 2000-08-05 20:43:47 UTC
This appears to happen every time xscreensaver kicks in.

Comment 2 Jonathan Blandford 2001-01-10 16:19:17 UTC
Does this happen with 7.0?


Comment 3 Steve Kann 2001-02-01 16:49:02 UTC
I am having a problem with RH-7.0 and the tasklist as well, which may be similar
to yours.

Occasionally, the tesklist starts growing larger and larger, without bound.
I've seen it have a memory footprint of over 700MB.  Eventually, it will get
killed when the kernel decides I've just about run out of memory and swap.

Based on this, I'll try to see if this is correlated with the screensaver.

Comment 4 Jonathan Blandford 2001-07-13 19:38:17 UTC
I can't reproduce this at all, unfortunately.  Please let us know if you can
find reproduce this regularly.

Comment 5 Stas Sergeev 2001-12-06 22:54:49 UTC
I don't know how to help you to reproduce it, but about a year ago (on RH 6.2
or 7.0, don't remember now) I have found a way to get rid of this crashes. Then
I forgot about this problem, but recently I upgraded to 7.1 and found out that
the problem is still there, the only change is that now I asked to restart the
applet.
I dusted out my workaround, applied it and no crashes again.
I'll attach it now, give it a try. I don't know why it works, however:)
But I hope it will help you to fix a problem.
BTW, this have nothing to do with the bug where tasklist eats 700Mb.


Comment 6 Stas Sergeev 2001-12-06 22:56:58 UTC
Created attachment 39967 [details]
patch to work around the problem, works for me (only?)

Comment 7 Stas Sergeev 2001-12-06 23:15:23 UTC
BTW, seems that it happens only with SawFish being a window manager.

Comment 8 Jay Turner 2003-04-14 18:49:43 UTC
Closing out due to bit-rot.


Note You need to log in before you can comment on or make changes to this bug.