Bug 1548443 - OSP13: Deployment with Ceph fails over parameter_groups.deprecated: : The parameters must be provided for each parameter group.
Summary: OSP13: Deployment with Ceph fails over parameter_groups.deprecated: : The par...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Jiri Stransky
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-23 14:32 UTC by Omri Hochman
Modified: 2018-06-27 13:46 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180215092255.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:45:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1750828 None None None 2018-02-23 14:35:49 UTC
OpenStack gerrit 546642 None MERGED Fix invalid Ceph and BlockStorage role template 2020-08-05 01:47:20 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:46:28 UTC

Description Omri Hochman 2018-02-23 14:32:44 UTC
OSP13: Deployment with Ceph fails over parameter_groups.deprecated: : The parameters must be provided for each parameter group.


Environment:
-------------
openstack-tripleo-heat-templates-8.0.0-0.20180215092254.el7ost.noarch
puppet-ceph-2.4.1-0.20180213002137.beb5277.el7ost.noarch
ceph-ansible-3.0.14-1.el7cp.noarch


Related to issue :https://bugs.launchpad.net/tripleo/+bug/1750828
propusd patch:  https://review.openstack.org/#/c/546642/


Steps :
--------
(1) Attempt to deploy osp13 with Ceph


Results:
---------
:////4BXPwIMOpT+dGkGjFb3MbU+jLBm5txgf0wOxsBu9Gf+XAAAAzB+LCAAAAAAAAP9b85aBtbiIQSOjNKU4P0+vIKc0PTOvWK8kMze1uCQxtyC1SC8ExvbLL0llgABGJgYmLwaB3MycnMzi4My85FTXgvzkDB8G3tScxILi1BRfsEwJg4BPVmJZon5OYl66vk9+Xrp1RRGDFNSy5Py84vycVD1nCI1qPENFAZBOPKh14yTQfXwgU/RApuiBTel+MuFMv/J9JgZGLwbWssSc0lSguQIIRX6luUmpRW1rpspyT3nQDTUNCEKluwGZxoFI8gAAAA==[0m                                                                                    u'queue_name': u'<% $.queue_name %>',
05:37:46                                                                                     u'use_default_templates': True},
05:37:46                                                                          u'name': u'create_swift_rings_backup_plan',
05:37:46                                                                          u'on-error': u'create_swift_rings_backup_plan_set_status_failed',
05:37:46                                                                          u'on-success': u'cell_v2_discover_hosts',
05:37:46                                                                          u'type': u'direct',
05:37:46                                                                          u'version': u'2.0',
05:37:46                                                                          u'workflow': u'tripleo.swift_rings_backup.v1.create_swift_rings_backup_container_plan'},
05:37:46                                      u'create_swift_rings_backup_plan_set_status_failed': {u'name': u'create_swift_rings_backup_plan_set_status_failed',
05:37:46                                                                                            u'on-success': u'send_message',
05:37:46                                                                                            u'publish': {u'message': u'<% task(create_swift_rings_backup_plan).result %>',
05:37:46                                                                                                         u'status': u'FAILED'},
05:37:46                                                                                            u'type': u'direct',
05:37:46                                                                                            u'version': u'2.0'},
05:37:46                                      u'deploy': {u'action': u'tripleo.deployment.deploy',
05:37:46                                                  u'input': {u'container': u'<% $.container %>',
05:37:46                                                             u'skip_deploy_identifier': u'<% $.skip_deploy_identifier %>',
05:37:46                                                             u'timeout': u'<% $.timeout %>'},
05:37:46                                                  u'name': u'deploy',
05:37:46                                                  u'on-error': u'set_deployment_failed',
05:37:46                                                  u'on-success': u'send_message',
05:37:46                                                  u'type': u'direct',
05:37:46                                                  u'version': u'2.0'},
05:37:46                                      u'run_validations': {u'input': {u'group_names': [u'pre-deployment'],
05:37:46                                                                      u'plan': u'<% $.container %>',
05:37:46                                                                      u'queue_name': u'<% $.queue_name %>'},
05:37:46                                                           u'name': u'run_validations',
05:37:46                                                           u'on-error': u'set_validations_failed',
05:37:46                                                           u'on-success': u'create_swift_rings_backup_plan',
05:37:46                                                           u'type': u'direct',
05:37:46                                                           u'version': u'2.0',
05:37:46                                                           u'workflow': u'tripleo.validations.v1.run_groups'},
05:37:46                                      u'send_message': {u'action': u'zaqar.queue_post',
05:37:46                                                        u'input': {u'messages': {u'body': {u'payload': {u'execution': u'<% execution() %>',
05:37:46                                                                                                        u'message': u"<% $.get('message', '') %>",
05:37:46                                                                                                        u'status': u"<% $.get('status', 'SUCCESS') %>"},
05:37:46                                                                                           u'type': u'tripleo.deployment.v1.deploy_plan'}},
05:37:46                                                                   u'queue_name': u'<% $.queue_name %>'},
05:37:46                                                        u'name': u'send_message',
05:37:46                                                        u'on-success': [{u'fail': u'<% $.get(\'status\') = "FAILED" %>'}],
05:37:46                                                        u'retry': u'count=5 delay=1',
05:37:46                                                        u'type': u'direct',
05:37:46                                                        u'version': u'2.0'},
05:37:46                                      u'set_deployment_failed': {u'name': u'set_deployment_failed',
05:37:46                                                                 u'on-success': u'send_message',
05:37:46                                                                 u'publish': {u'message': u'<% task(deploy).result %>',
05:37:46                                                                              u'status': u'FAILED'},
05:37:46                                                                 u'type': u'direct',
05:37:46                                                                 u'version': u'2.0'},
05:37:46                                      u'set_validations_failed': {u'name': u'set_validations_failed',
05:37:46                                                                  u'on-success': u'send_message',
05:37:46                                                                  u'publish': {u'message': u'<% task(run_validations).result %>',
05:37:46                                                                               u'status': u'FAILED'},
05:37:46                                                                  u'type': u'direct',
05:37:46                                                                  u'version': u'2.0'}},
05:37:46                           u'version': u'2.0'},
05:37:46                 u'updated_at': u'2018-02-20 21:08:52'},
05:37:46  u'message': u"Failed to run action [action_ex_id=462d8f77-ad06-41c2-986a-bcd94158d468, action_cls='<class 'mistral.actions.action_factory.DeployStackAction'>', attributes='{}', params='{u'skip_deploy_identifier': False, u'container': u'overcloud', u'timeout': 240}']\n ERROR: Parameter Groups error: : resources.CephStorage<nested_stack>.resources.0<https://192.168.0.2:13808/v1/AUTH_623d8de684f44a6fb4e210529b2d2702/overcloud/puppet/cephstorage-role.yaml>.parameter_groups.deprecated: : The parameters must be provided for each parameter group.",
05:37:46  u'status': u'FAILED'}
05:37:46 Started Mistral Workflow tripleo.validations.v1.check_pre_deployment_validations. Execution ID: 753f4286-01b9-4845-9250-3a8ab3c537ca
05:37:46 Removing the current plan files
05:37:46 Uploading new plan files
05:37:46 Started Mistral Workflow tripleo.plan_management.v1.update_deployment_plan. Execution ID: dea95ef3-6e66-4f9c-a554-c884f6bdddb2
05:37:46 Plan updated.
05:37:46 Processing templates in the directory /tmp/tripleoclient-fDcCeL/tripleo-heat-templates
05:37:46 Started Mistral Workflow tripleo.plan_management.v1.get_deprecated_parameters. Execution ID: d31562f0-2d90-45df-b60d-c0e4dd3acf2c
05:37:46 WARNING: Following parameters are deprecated and still defined. Deprecated parameters will be removed soon!
05:37:46   OvercloudControlFlavor
05:37:46 WARNING: Following parameters are defined but not used in plan. Could be possible that parameter is valid but currently not used.
05:37:46   ControlPlaneDefaultRoute
05:37:46   CephAnsiblePlaybookVerbosity
05:37:46   CephAnsibleExtraConfig
05:37:46   TenantNetCidr
05:37:46   SSLIntermediateCertificate
05:37:46   InternalApiAllocationPools
05:37:46   CinderBackupBackend
05:37:46   StorageMgmtAllocationPools
05:37:46   StorageMgmtNetCidr
05:37:46   CephAnsibleDisksConfig
05:37:46   DockerMysqlClientConfigImage
05:37:46   DockerCephDaemonImage
05:37:46   CephPoolDefaultPgNum
05:37:46   ExternalNetCidr
05:37:46   StorageMgmtNetworkVlanID
05:37:46   SSLKey
05:37:46   TenantAllocationPools
05:37:46   ExternalAllocationPools
05:37:46   EC2MetadataIp
05:37:46   InternalApiNetCidr
05:37:46   DnsServers
05:37:46   StorageAllocationPools
05:37:46   StorageNetCidr
05:37:46   StorageNetworkVlanID
05:37:46   CephAnsiblePlaybook
05:37:46   ExternalInterfaceDefaultRoute
05:37:46 Deploying templates in the directory /tmp/tripleoclient-fDcCeL/tripleo-heat-templates
05:37:46 Started Mistral Workflow tripleo.deployment.v1.deploy_plan. Execution ID: 19d040a5-2b15-4a75-a592-922f47cafa5f

Comment 3 Alexander Chuzhoy 2018-02-23 17:47:03 UTC
Reproduced.

Comment 6 Omri Hochman 2018-03-18 14:00:05 UTC
Verified with openstack-tripleo-heat-templates-8.0.0-0.20180304031146.6cd4184.el7ost.noarch

Comment 9 errata-xmlrpc 2018-06-27 13:45:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.