Bug 1548446 - System Tray Icon no longer available in gnome 3.26 in RHEL 7 out of the box
Summary: System Tray Icon no longer available in gnome 3.26 in RHEL 7 out of the box
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.5
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
Lucie Maňásková
URL:
Whiteboard:
Depends On:
Blocks: 1549666
TreeView+ depends on / blocked
 
Reported: 2018-02-23 14:51 UTC by James Hartsock
Modified: 2018-08-23 16:42 UTC (History)
8 users (show)

Fixed In Version: gnome-shell-extensions-3.26.2-3.el7
Doc Type: Known Issue
Doc Text:
System tray icons no longer available in *GNOME Shell* The system tray icons that showed on the top of the screen are no longer available in *GNOME Shell* version 3.26 in Red Hat Enterprise Linux. As a workaround, you can install the *TopIcons Plus* extension for *GNOME Shell* which moves status icons to the top bar.
Clone Of:
Environment:
Last Closed: 2018-04-10 13:13:04 UTC


Attachments (Terms of Use)
Enable top-icons extension in default session (3.75 KB, patch)
2018-02-23 16:08 UTC, Florian Müllner
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 13:13:16 UTC
Red Hat Knowledge Base (Solution) 3362871 None None None 2018-02-23 14:51:44 UTC

Description James Hartsock 2018-02-23 14:51:44 UTC
Description of problem:
Applications like SpiderOakGroup (backup utility), synergy (sofware KVM switch), etc still utilize system tray icon that was removed in gnome 3.23 and included in RHEL 7.5

Version-Release number of selected component (if applicable):
RHEL 7.5 Beta
gnome-shell-3.26.2-4.el7.x86_64


How reproducible:
VERY

Steps to Reproduce:
Using synergy from 
1. From Fresh RHEL 7.5 HTB GNOME desktop start synergy.
   Note: I am doing via ssh, as that remote system has installed aleady

   $ ssh -X host1 "synergy --client -f"
   -or spider oak-
   $ ssh -X host2 "/usr/bin/SpiderOakGroups"

2. Wait


Actual results:

  $ ssh -X bock "synergy --client -f"
  "sni-qt/23671" WARN  07:28:46.710 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE 
  QMetaObject::connectSlotsByName: No matching signal for on_windowShown()
  *** WARNING *** The program 'synergy' uses the Apple Bonjour compatibility layer of Avahi.
  *** WARNING *** Please fix your application to use the native API of Avahi!
  *** WARNING *** For more information see <http://0pointer.de/blog/projects/avahi-compat.html>
  No systemtrayicon available

  In addition get pop-up window that states:
    System tray is unavailable, don't close your window.

  -or-

  $ ssh -X t470s "/usr/bin/SpiderOakGroups"
  "sni-qt/1977" WARN  07:36:27.388 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE 
  No systemtrayicon available



Expected results:
  In RHEL 7.0 - 7.4 these applications work out of the box, users will expect the same when install RHEL 7.5

Work-Around:
  Install & Enable: (dbus or gnome-tweak-tool) the gnome-shell-extension-top-icons

Additional info:
  https://blogs.gnome.org/aday/2017/08/31/status-icons-and-gnome/
  https://wiki.gnome.org/Initiatives/StatusIconMigration
  https://github.com/symless/synergy-core/issues/5304
  https://github.com/symless/synergy-core/issues/6173
  https://support.spideroak.com/hc/en-us/articles/115005891286-Icon-on-Gnome

Comment 4 Florian Müllner 2018-02-23 16:08:09 UTC
Created attachment 1399921 [details]
Enable top-icons extension in default session

The easiest option to address this is to install and enable the already packaged top-icons extension by default.

Comment 7 Jiri Koten 2018-02-28 14:29:33 UTC
gnome-shell-extension-top-icons is now dependency of gnome-classic-session and is enabled by default in Gnome Classic Session.

There is an issue with auto-started applications and systray - see rhbz#1550115 for more details.

Comment 8 James Hartsock 2018-02-28 14:31:08 UTC
This issue was seen in the standard GNOME session, not GNOME classic session.

Comment 9 James Hartsock 2018-02-28 15:18:48 UTC
Downloaded the build from brew, looks like top-icons is enabled for both gnome & gnome classic.

Comment 14 errata-xmlrpc 2018-04-10 13:13:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.