This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 154858 - Users Tab -> Removing roles from yourself
Users Tab -> Removing roles from yourself
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Bowman
Red Hat Satellite QA List
:
Depends On:
Blocks: rhnMilestone1
  Show dependency treegraph
 
Reported: 2005-04-14 12:06 EDT by Michael Bowman
Modified: 2007-04-18 13:23 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-27 14:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Bowman 2005-04-14 12:06:07 EDT
This doesn't work in the java code. 

A user should be able to remove roles from themselves on the user details page.
Comment 1 Michael Bowman 2005-04-19 12:45:41 EDT
Users can now remove roles from themselves in Java.

However, the user details page still needs some work. If a user removes org
admin status from themselves, they should be redirected off of this page:
http://mbowman.rdu.redhat.com/rhn/users/UserDetails.do?uid=4169969
To something where they cannot edit roles.

Waiting on java webapp security meeting to decide how to handle this, since if
we implement page security correctly, this problem should solve itself.

Comment 2 Michael Bowman 2005-06-20 12:11:28 EDT
Using struts acls now. See bz # 160809

Note You need to log in before you can comment on or make changes to this bug.