Bug 1548996 - Mount option in storage class does not take effect for the efs dynamic provisioner
Summary: Mount option in storage class does not take effect for the efs dynamic provis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Tomas Smetana
QA Contact: Chao Yang
URL:
Whiteboard:
: 1548982 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-26 08:21 UTC by Chao Yang
Modified: 2018-07-30 19:10 UTC (History)
5 users (show)

Fixed In Version: openshift-external-storage-0.0.2-1.gitd3c94f0.el7
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:09:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:10:18 UTC

Description Chao Yang 2018-02-26 08:21:44 UTC
Description of problem:
Efs/NFS dynamic provisioner does not support mount option for StorageClass

Version-Release number of selected component (if applicable):
[root@ip-172-18-6-178 ~]# oc version
oc v3.9.0-0.51.0
kubernetes v1.9.1+a0ce1bc657
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ip-172-18-6-178.ec2.internal:8443
openshift v3.9.0-0.51.0
kubernetes v1.9.1+a0ce1bc657

How reproducible:
Always
Steps to Reproduce:
1.Create a storageclass with mountoption tcp ro
[root@ip-172-18-6-178 ~]# oc get sc slow -o yaml
apiVersion: storage.k8s.io/v1
kind: StorageClass
metadata:
  annotations:
    storageclass.beta.kubernetes.io/is-default-class: "false"
  creationTimestamp: 2018-02-26T08:06:02Z
  name: slow
  resourceVersion: "35027"
  selfLink: /apis/storage.k8s.io/v1/storageclasses/slow
  uid: e32f181b-1acb-11e8-883b-0efd92eaefde
mountOptions:
- tcp
provisioner: openshift.org/aws-efs
reclaimPolicy: Delete
2.Create a dynamic pvc
[root@ip-172-18-6-178 ~]# oc get pvc
NAME      STATUS    VOLUME                                     CAPACITY   ACCESS MODES   STORAGECLASS   AGE
efspvc    Bound     pvc-e6d2005a-1acb-11e8-883b-0efd92eaefde   1Gi        RWO            slow           3m

3.Check the pv yaml file
[root@ip-172-18-6-178 ~]# oc get pv pvc-e6d2005a-1acb-11e8-883b-0efd92eaefde -o yaml
apiVersion: v1
kind: PersistentVolume
metadata:
  annotations:
    pv.beta.kubernetes.io/gid: "2000"
    pv.kubernetes.io/provisioned-by: openshift.org/aws-efs
  creationTimestamp: 2018-02-26T08:06:09Z
  name: pvc-e6d2005a-1acb-11e8-883b-0efd92eaefde
  resourceVersion: "35053"
  selfLink: /api/v1/persistentvolumes/pvc-e6d2005a-1acb-11e8-883b-0efd92eaefde
  uid: e7509909-1acb-11e8-883b-0efd92eaefde
spec:
  accessModes:
  - ReadWriteOnce
  capacity:
    storage: 1Gi
  claimRef:
    apiVersion: v1
    kind: PersistentVolumeClaim
    name: efspvc
    namespace: 6wqts
    resourceVersion: "35041"
    uid: e6d2005a-1acb-11e8-883b-0efd92eaefde
  nfs:
    path: /efspvc-pvc-e6d2005a-1acb-11e8-883b-0efd92eaefde
    server: fs-c8e05981.efs.us-east-1.amazonaws.com
  persistentVolumeReclaimPolicy: Delete
  storageClassName: slow
status:
  phase: Bound


Actual results:
PV is not annotated with mount option

Expected results:
PV is annotated with mount option
Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:

Comment 1 Chao Yang 2018-02-26 08:22:14 UTC
*** Bug 1548982 has been marked as a duplicate of this bug. ***

Comment 2 Jan Safranek 2018-02-26 08:57:29 UTC
This is basically the same as #1547884. We need rebase external provisioner in 3.10.

Comment 4 Chao Yang 2018-05-16 06:19:20 UTC
It is passed on the
openshift v3.10.0-0.46.0
kubernetes v1.10.0+b81c8f8

Comment 6 errata-xmlrpc 2018-07-30 19:09:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.