Bug 1549000 - line-coverage tests not capturing details properly.
Summary: line-coverage tests not capturing details properly.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
Assignee: Amar Tumballi
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-26 08:30 UTC by Amar Tumballi
Modified: 2018-06-20 18:01 UTC (History)
2 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-17 09:29:03 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Amar Tumballi 2018-02-26 08:30:35 UTC
Description of problem:
Check https://build.gluster.org/job/line-coverage/226/Line_Coverage_Report/ and check xlators/features/sdfs/ coverage. It is 0 even though the translator is now being executed sdfs-sanity.t

Version-Release number of selected component (if applicable):
master

How reproducible:
100%

Expected results:
The line coverage should capture all these executions.

Comment 1 Worker Ant 2018-02-26 08:31:54 UTC
REVIEW: https://review.gluster.org/19629 (tests: don't kill the process directly with KILL signal) posted (#1) for review on master by Amar Tumballi

Comment 2 Worker Ant 2018-03-08 14:22:27 UTC
COMMIT: https://review.gluster.org/19629 committed in master by "Xavi Hernandez" <xhernandez@redhat.com> with a commit message- tests: don't kill the process directly with KILL signal

Instead send the SIGTERM (default, 15) first, and at the end
send SIGKILL. If SIGKILL is sent directly, we miss many tests
like valgrind, lcov etc., not able to process the information
properly.

BUG: 1549000
Change-Id: I664de12ee7dbf47eb98b8141004cd51f6006b314
Signed-off-by: Amar Tumballi <amarts@redhat.com>

Comment 3 Amar Tumballi 2018-04-17 09:29:03 UTC
Latest master is all fine. As this doesn't need a specific release, closing the issue.

Comment 4 Shyamsundar 2018-06-20 18:01:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.