Bug 1549042 - Kernels 4.15.x are not booting on docking
Summary: Kernels 4.15.x are not booting on docking
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1549169 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-26 10:10 UTC by Marko Bevc
Modified: 2018-03-23 17:59 UTC (History)
39 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-03-16 18:02:25 UTC
Type: Bug


Attachments (Terms of Use)
Picture from failing boot - T470s docked (708.11 KB, image/jpeg)
2018-03-06 14:48 UTC, Milan Zink
no flags Details


Links
System ID Private Priority Status Summary Last Updated
FreeDesktop.org 105470 0 None None None 2018-03-12 23:17:50 UTC
Red Hat Bugzilla 1549169 0 urgent CLOSED Lenovo ThinkPad T470s hang on boot while in docking station 2021-02-22 00:41:40 UTC

Internal Links: 1549169

Description Marko Bevc 2018-02-26 10:10:18 UTC
Description of problem:
When trying to boot Lenovo X260 on a docking station I get a black screen on F27 with latest kernels 4.15.x. Works fine on VM or without a docking station.

How reproducible:


Steps to Reproduce:
1. Update to kernel branch 4.15.x on F27
2. Reboot using a Lenovo X260 on docking station
3. Boot stops on black screen

Actual results:
Black screen - boot errors out.

Expected results:
Successful boot.

Additional info:
-

Comment 1 Syquus 2018-02-26 11:18:50 UTC
I was experiencing a similar bug UNTIL 4.15.4-300 came out. I upgraded just a few hours ago.

My exact problem was:
- X260 with closed lid permanently. (if it affects somehow due to the native display not being present at higher levels)
- not using a Lenovo Dock Station but a HDMI Monitor (Display #1) and a miniDP Monitor (Display #2)
- While Booting from kernels before 4.15.4 (4.14.18 or 4.15.3 for example) THIS HAPPENED:
1. Gnome login prompt showed up seamslessly.
2. After choosing user and password, both displays shut down.
3. Keyboard Num light also went down, assuming USB power was down (no response from keyboard)

Workaround: At that moment, pressing the laptop Power button resumed both keyboard and displays activity. Gnome session showed with no lock screen. Directly to the desktop.

Worth mentioning, just in case: This laptop has UEFI Secure Bios enabled (Tons of problems related til now).

But as I said, the problem regarding the black screen (which I couldn't find the exact cause) has disappeared in 4.15.4. I cannot reproduce with the same steps above.

I hope you can fix yours soon.

Regards

Comment 2 Syquus 2018-02-26 11:52:12 UTC
Forget my previous comment about 4.15.4-300. The problem has reproduced again just now with 4.15.4-300 too.

So my problem is still there.

Regards

Comment 3 Laura Abbott 2018-02-27 18:47:18 UTC
Your best bet is to do a bisect on the upstream kernel to find out which commit broke.

Comment 4 Robert Story 2018-02-28 13:13:49 UTC
I also can't boot while docked, though I have a Lenovo P50.

see also bz#1535587 and bz#1527669 (which are both about Lenovo P50 laptops that won't boot while docked).

Comment 5 Marko Bevc 2018-03-01 12:41:52 UTC
Still not booting on 4.15.6-300.fc7; getting this error for intel_drm: CPU FIFO B underrun

Comment 6 Marko Bevc 2018-03-01 12:48:17 UTC
Laura, I reckon somewhere at 18/01/2018 code this was already broken:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git/log/?h=v4.15.7&qt=grep&q=drm

Comment 7 javiertury 2018-03-01 14:11:17 UTC
Marko, I had the same problem as you. The message "intel_drm: CPU FIFO B underrun" was printed and the booting process stalled. This happened with kernels 4.15.4-300, 4.15.5-300 and 4.15.6-300 when the t470 was in the ultra dock.

What I did was to upgrade the bios to 1.46 and it solved the problem. Previously I had bios 1.43 or 1.44.

Comment 8 Marko Bevc 2018-03-01 14:35:09 UTC
Hm, there is a newer BIOS available :o I'll try that as well, I'm on 1.35 and 1.36 got our recently.

Comment 9 Marko Bevc 2018-03-01 18:42:11 UTC
No luck, same thing on latest BIOS code 1.36 - Lenovo 1.36....

Comment 10 javiertury 2018-03-01 19:03:04 UTC
As far as I can remember, intel released early microcode updates with bugs after meltdown and spectre were disclosed. On February intel released again updates for some of the chips with meltdown/spectre mitigations and fixed the bugs.

The latest BIOS updates for x260 and P50 were released before February 2018, probably they still contain the buggy microcode. On the other hand, bear in mind that I'm not an expert on the subject.

Comment 11 Marko Bevc 2018-03-01 19:25:46 UTC
Yeah, first release was retracted in January - this is second release and should be ok. But perhaps there will be another one released as well :) Thanks for you feedback!

Comment 12 Stepan Broz 2018-03-04 12:34:56 UTC
Updated firmware on T470s, no luck.

Comment 13 Werner Gold 2018-03-06 09:06:51 UTC
Same for my T460S
BIOS Information
        Vendor: LENOVO
        Version: N1CET65W (1.33 )
        Release Date: 02/16/2018

Every 4.15 Kernel fails to boot in the dock so far.

Comment 14 javiertury 2018-03-06 10:24:16 UTC
Previously I reported that the issue was gone after a bios update. I was wrong. This morning the message "intel_drm: CPU FIFO B underrun" appeared after booting kernel 4.15.6-300. Probably the bios update didn't do anything and I just hit a lucky streak.

Comment 15 Milan Zink 2018-03-06 14:44:02 UTC
Tested 4.15.7-300. Problem appears only when laptop lid is closed during boot.

There's no signal on external monitors HDMI & DP connected to dock. 1 of them or both, no difference.

Booting is fine if un-docked or lid opened.

Comment 16 Milan Zink 2018-03-06 14:48:08 UTC
Created attachment 1404859 [details]
Picture from failing boot - T470s docked

Errors:
drm:intel_cpu_fifo_underrun_irq_handler [i915] *ERROR*  pip B FIFO underrun
drm:intel_mst_enable_dp [i915] *ERROR* Timed out waiting for ACT sent

Comment 17 Laura Abbott 2018-03-12 23:17:51 UTC
Since someone noted it was reproducible on a T470s I did the bisect and came up with a graphics commit. Filed upstream.

Comment 18 Laura Abbott 2018-03-12 23:19:12 UTC
*** Bug 1506339 has been marked as a duplicate of this bug. ***

Comment 19 Pierre Wakim 2018-03-13 11:37:03 UTC
The same issue is occurring with me with my Lenovo T460s. Fortunately, I am still having the 4.14.18-300.fc27.x86_64 kernel to boot with it while docked.

Comment 20 Pierre Wakim 2018-03-13 12:10:57 UTC
The error is occurring while docked, with either the lid is opened or closed.

Booting is fine with kernel 4.15.xx while the notebook is not docked.

Comment 21 Stepan Broz 2018-03-13 12:26:20 UTC
The server boots up undocked or with the lid opened, however, there is still the error message, at least on my T470s:

"[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun"

Comment 22 Stepan Broz 2018-03-13 12:27:13 UTC
*** Bug 1549169 has been marked as a duplicate of this bug. ***

Comment 23 Ian Pilcher 2018-03-14 19:23:22 UTC
Random thought ... Does booting with i915.enable_dp_mst=0 help?

Comment 24 Laura Abbott 2018-03-14 19:58:29 UTC
https://koji.fedoraproject.org/koji/taskinfo?taskID=25702749 please test this scratch build which should have the fix. Assuming there are no other regressions I'll throw this into the next F26/F27 build.

Comment 25 Marko Bevc 2018-03-14 20:53:34 UTC
Laura, good catch! Works on X260 here as well, thanks. I think it is safe to push it forward if there won't be any other issues.

Comment 26 Stepan Broz 2018-03-15 08:17:01 UTC
Amazing work on this bug, Laura! The scratch-build of 4.15.9-301 resolves the issue for me on my T470s.

Comment 27 Milan Zink 2018-03-15 09:07:15 UTC
Thank you, Laura. Scratch-build of 4.15.9-301 resolves the issue. (ThinkPad T470s)

Comment 28 Angelo Lisco 2018-03-15 10:06:34 UTC
Green light also here on a T460s
Thanks a lot, Laura!

Comment 29 Dave Kline 2018-03-15 13:59:53 UTC
Confirming the Koji build above fixes my t460s.

Comment 30 Fedora Update System 2018-03-16 00:36:05 UTC
kernel-4.15.10-300.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-959aac67a3

Comment 31 Fedora Update System 2018-03-16 00:37:23 UTC
kernel-4.15.10-200.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-296bf0c332

Comment 32 Fedora Update System 2018-03-16 17:25:20 UTC
kernel-4.15.10-200.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-296bf0c332

Comment 33 Fedora Update System 2018-03-16 17:56:17 UTC
kernel-4.15.10-300.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-959aac67a3

Comment 34 Marko Bevc 2018-03-16 18:02:56 UTC
Issue resolved, closing.

Comment 35 Fedora Update System 2018-03-20 17:35:47 UTC
kernel-4.15.10-200.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 36 Fedora Update System 2018-03-20 18:22:07 UTC
kernel-4.15.10-300.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 37 Robert Story 2018-03-23 17:56:50 UTC
My Lenovo P50 still won't boot while docked, even after upgrading to 4.15.10-300.fc27.x86_64. After boot starts I might get a nouveau MMIO read error line, but mostly the screen just goes black.

Comment 38 Laura Abbott 2018-03-23 17:59:51 UTC
Please file a separate bug for the nouveau issue, the fix for this issue was in i915


Note You need to log in before you can comment on or make changes to this bug.